Gear VR Black screen on some Samsung Galaxy S7 and S8

Me and my team are currently working on a game for the Gear VR that is soon to be released and we are in close contact with Oculus. However the team at Oculus can’t play our game on their Samsung phones (Both S7 and S8), the game starts and they can hear sound but the screen is completely black. Since it works on our S8 and S7 we are thinking this is an issue with chipsets and are wondering if this is a known issue?

We are using Unreal Engine 4.16 and we have European versions of the Samsung galaxies (Exynos chipset). It is really hard to debug the issue since we have to upload it to our alpha channel and wait for response from oculus anytime we want to try a fix. So if anyone knows of a solution to this problem we would be very thankful!

I have this problem in 4.16 on the US Adreno s8… but another team member didn’t on his S7.

I haven’t looked at gearVR for a couple of weeks (we are primarily aiming for cardboard) but ill do a build tomorrow and see if I’m still having the problem… it never used to have it it just… happened one day.

Weirdly if I turned on “Mobile Mutli-view Direct” (Engine - Rendering > VR) it totally worked but the performance was really bad.

Hi! We upgraded to 4.17 and now the issue seems to be resolved. At least our contact at oculus was able to start our game on a samsung galaxy with the snapdragon chipset

I found a solution to this problem in the Unity forums.
Some devs had the exact some issue and they fixed it by disabling the Google VR Service on their devices.
For me this worked like a charm for pretty much all UE4 apps that were having this problem before.