Download

GEAR VR Android NDK Version For Marshmallow Galaxy S7 Question

I have had successful builds in Unreal 4.11 using the same project on Galaxy Note 4, and the GalaxyS6. ETC2 textures and I was using SDK-19 was working flawlessly on Gear VR. I just bought a Galaxy S7 and exported out a project in VR in 4.11 and it is not working. I do not know which SDK or NDK to use for the Marshmallow OS for the Galaxy S7. Do I use the android-21 or the android-23 for Marshmallow. The highest I ever used was Lollipop 19. Any help would be appreciated.

Hi lafilmcompany, I had the same issue. You’ve probably just missed my thread as it slid to the second page: https://forums.unrealengine.com/showthread.php?106338-Can-t-package-on-GearVR-with-Samsung-S7-Edge-on-4-11-0
I installed the SDK and co. files from nvidia directly so I had the latest versions of everything which was why my build didn’t work. What I did at Chris Babcock’s suggestion was to specify android-21" for the SDK API level and “android-19” for NDK API level. I used ETC2 texture compression in the package options. Afterwards I’ve applied the installation process described here: https://docs.unrealengine.com/latest/INT/Platforms/GearVR/QuickStart/3/index.html. Just make sure you have the phone drivers properly installed on your PC and have developer mode active on the phone. I used an S7 Edge.

Thank You do much for your response. I got it to work and package to Samsung VR and show up, but when I move the camera around it shuts off and exits. I packaged several times. I am using the Third Person Blueprint. I can run straight forward and back, but when I move thecamera the app closes.

android1.png
android2.jpg

I’m not sure to which extent the third person camera setup is suitable for VR, at least in the way it’s been designed. In VR the camera pivots from it’s center, in third person it pivots from the spring pivot. At this point it’s up to you to start debugging and implementing various camera set-ups.

I’ve no problems at all with my S7 Edge - but I’ve seen other people report it: https://forums.unrealengine.com/showthread.php?60371-Epic-s-low-priority-on-GearVR-and-VR-in-general-makes-me-sad&p=511670&viewfull=1#post511670
So I wonder if it’s related to the model of the device and / or Oculus Systems Activities version?

Which exact model (Settings - about - model) and which Oculus Systems Activities version (setttings - application manager - Oculus Systems Activities) do you have?

Same issue here, I asked on AnswerHub but didn’t mark it as a bug yet, since I was not sure if its Unreal’s fault. Other Apps from the Oculus store work fine tho.