Game Module could not be found

I noticed this question has been asked before but there was no solution mentioned so I am putting it out here again.

I am on Mac OSX 10.9. i7 2.6Ghz 16GB RAM.

Following are the repro steps. Repro rate is 100%.

  1. Open UE4 Editor. Start a blank project. Dont import starter content.
  2. File->Add code to project. Create a Dummy class
  3. Close the editor
  4. Add BeginPlay(). Display “Hello world” on the screen.
  5. Compile. Select target ($ProjectName) → Mac (I also tried ($ProjectName)Editor → Mac)
  6. Build Successful
  7. Go to unreal launcher. Launch the editor and error (attached). Cant do anything.

I tried above steps 3 or 4 times before giving up.
I also tried right-clicking on the .uproject and selecting ‘Generate XCode Files’, then recompiling still no success.

Please let me know what I am missing. Cant do a thing right now.


So after creating millions of projects and trying various combinations I finally figured out the problem.

In XCode, chose ($ProjectName)Editor → My Mac as your compile target and then Product → Build For → Profiling.
This worked for me and I am able to open the project in in the editor. Compiling for any other configuration seems to produce “Game Module not found” error as mentioned above.

May be it was documented somewhere but I couldn’t find it. At least its working now :slight_smile:

Thanks! This worked for me on OSX 10.9.2 with XCode 5.1.

I’m considering building from Source so I can take advantage of this answer:

Thanks you so much! “Build for Profiling” did it.