Game files required to initialize the global shader library are missing from - Please make sure the game is installed correctly

I am getting the following message when packaging a project file - game files required to initialize the global shader library are missing - then the executable doesn’t open. I used the datasmith plugin to import the assets, everything passes integrity checks, no errors are found the project itself.

Same here. In my case, it happened the moment I updated the GDK to 4.27-17939503.

I’m going to have to rollback and rebuild fresh. :frowning:

I did some research and setting Win64 fixed it.

1 Like

Hi, faced the same issue in the following scenario :

Unreal Engine 5.0.1
VR Project

First, opening the material editor would crash the engine.
That was fixed by switching from DX12 to DX11 and from other forum posts, it should be fixed in 5.0.2.

But then that caused the packaging issue where we would have the “game files required to initialize the global shader library are missing” error message.

That was solved by switching back to DX12 for the packaging.

3 Likes

There are two situations you’ll likely see this error:

  1. you are trying to launch the editor, but accidentally have DebugGame selected (instead of DebugGame Editor).
  2. You are trying launch DebugGame (without editor) but you’ve yet to package your project. Essentially when you run DebugGame it will go and look for files in your binary folders (I think) to run your game. If you’ve not gone to File > Package project, you are likely not to have the required files. The package process creates these files. Be sure that you go into Package settings and select the appropriate target (for example, if you’re trying to launch Debug Game, then you should change it from the default of Shipping to Debug Game)
36 Likes

You could just link my answer in this thread, rather than just copy and paste it:
Project crashing due to “missing game files” - Unreal Engine / Platform & Builds - Unreal Engine Forums

I just had this issue again when installing repo on a new device, and accidentally launching Development config in Visual Studio, instead of Development Editor.

6 Likes

Hi,

I had this issue after packaging when I wanted to start the .exe.
I have targeted RHI Vulkan. I went to Project Settings > Platforms > Windows > Targeted RHIs and checked the Vulkan (SM5) box additionally, then packaged anew and it worked

1 Like

Thank you!

1 Like

Hi,

Thanks a lot for your advice!

My case was the latter, I went for the DebugGame Configuration to be able to debug my Online Subsystem Code.

I’m using Unreal Engine 5 and went to Platforms > Windows and set the “Binary Configuration” to “DebugGame”
Then instead of “Package project” (which would export the files to a folder of my choice), I chose “Cook Content”. After that, I closed the Editor and restarted the Debug Session in Visual Studio.

It now works like a charm!

4 Likes

I had the same issue. This fixed my problem. Thank you!

This was my issue as well. I had not selected DebugGame Editor. Thanks alot!

This worked for me. Thanks!

This is the fix if you are trying to build it from Source is Visual Studio and you are launching the editor on smth else but You Can Use Ether DebugGame Editor or development Game Edtior or smth like that And Also Thank you Helo me with my Visual Studio Editor