Game editor performance does not match on standalone.

I kind of did a similar post to this in the past, but I need some help here what causes the performance on the editor viewport to run the game correctly and on standalone the game runs incorrectly “lower fps” from 60 in viewport to 40 in standalone?

Is resolution same? What is bottleneck cpu or gpu?

Resolution scale most likely. followed by shadows.

Got it fixed, turns out I had to create a DefaultUserGameSettings.ini file the issue was that the performance on standalone felt different compared to the editors viewport I actually wasn’t able to tell the difference between the two because they looked so identical but when I noticed that the grass was a little more further compared to the editor version I knew the issue was the engine was forcing the game to play at its highest like Cinematic when the game is suppose to be set to high.

Resolution scale is that like Dynamic Resolution Scaling in the new version?

The difference is that in the editor viewport the overall resolution is lower than compared with your game in standalone run. Lets suppose you desktop is set for Full HD (1920x1080) and when you run as standalone that will be the resolution it will use in Full Screen, while in the editor the amount available to the viewport is lower than 1920x1080. There are setting for you to change to ensure screen resolution, if windowed or full screen, if vertical sync is ON or OFF (limits framerate if ON) and also max framerate in the project settings must be set to “open” (usually is 60 or 62), and also the scalability settings (Low, Mid, High, Epic and Cinematic)

Supposing all this is set into your game, surely the performance will differ from the editor when compared with Standalone. Also, make sure before running standalone to press Ctrl+R to disable realtime at the viewport since it consumes some resources, which you can turn ON again by pressing Ctrl+R. You will know it is ON if particles and other animations are playing inside viewport when not running.