Download

Fullscreen too bright, not using Nvidia settings [Fixed]

I’ve noticed that my game is way too bright when I toggle fullscreen. The odd thing is that it effects the Steam overlay also. Here is a screenshot as a comparison:

](filedata/fetch?id=1831377&d=1605090109)
Forgive the quality, but I had to use my phone to capture the image. Oddly, if I use screen grab the brightness is correct.

I’ve tracked it down to this area in the Nvidia settings:

](filedata/fetch?id=1831378&d=1605090236)

In fullscreen mode the ‘Use Nvidia colour settings’ are not being applied.

I have an openGL version of my game and I don’t get the same brightness issue with that.

At this point I’m not sure if this is an Unreal problem or Nvidia. I’ve updated my drivers. The problem has also been reported by other people playing my game.

Any ideas?

Edit:
If I swap to Vulkan rendering the problem goes away (Other issues mean I can’t use this)

Using DX 11 means windowed is ok, but fullscreen is bright

Using DX 12 means windowed and fullscreen are bright. Still applies to Steam overlay so I know it’s not a level/camera/post processing issue.

It may require applying HDR settings to the project, and there’s a section about it in the docs. Using “Full Dynamic Range” in NVidia settings is similar, if not the equivalent, to enabling HDR across the board. Since HDR involves much higher or lower color values, the interpolation or transfer of color information from the game’s data to the device is probably not adapting right. Thus, an overly bright image because there’s an underlying attempt at calibrating to HDR values. What happens when switching from “Full Dynamic Range” to “Limited”? Try also to set bit-depth to 10 instead of 8, which fully supports HDR and HDR simulation (a type of higher dynamic range that is not true HDR, which is actually in a ton of devices that claim an HDR feature); the simulation HDR still requires a higher “Output Color Depth” and it’s more reliable using a DisplayPort 1.2+ than HDMI 2.0 (2.0b and 2.1 are HDR-compatible, I think, but anything older is suspect of not supporting it).

To explain a bit more regarding bit-depth for HDR support:

8 bits is VGA standard color range, so for each color in RGB it’s 00000000 to 11111111 (every combination of 1s and 0s with 8 digits per combination, or 8 bits)
That’s 256 combinations per channel, so 256 x 256 x 256 = approx. 16.8 million colors

10 bits is for HDR and simulated HDR, which is 1024 combinations per channel, so is 1024[SUP]3[/SUP] = approx. 1.07 billion colors

1.07 billion - 16.8 million = 1,053,200,000 more colors in HDR10, or 10-bit output color depth, than VGA / 8-bit

I’m not saying it is definitely the problem, but it could be, considering the Steam Overlay is affected too. However, the DX11 and DX12 differences put a damper on the notion of it being a problem with HDR because DX12 is supposed to be better with higher dynamic range than DX11. Is the switch from DX11 to DX12 done in-game (such as in options), or in the engine? Is the game for mobile and PC, console too?

Thanks for the info. I have found a solution which I think is related to what you’ve said.

In Project Settings->Rendering there’s an option ‘Frame Buffer Pixel Format’

You can choose from ‘8bit RGBA’, ‘Float RGBA’ or ‘10bit RGB 2bit Alpha’

I remember setting this to ‘Float RGBA’ as a test to see how the game looked. I never set it back, and this is was the problem.

Both ‘8bit RGBA’ and ‘10bit RGB 2bit Alpha’ give me the proper fullscreen brightness. However, ‘Float RGBA’ gives the over bright fullscreen results.

So I’ve fixed it by going back to ‘8Bit RGBA’.

I don’t know enough about how this all works to guess why the ‘float’ setting leads to this problem. but hopefully it might help someone dig it bit deeper.

Thanks for the tips.

Interesting. There’s a number of other possible causes I could’ve hypothesized, one of which is the pre-exposure setting to apply it before writing to the scene color, but I’m not understanding those aspects enough to describe exactly how it would be the cause or confirm it is. This HDR stuff is rather difficult to comprehend without the proper contextual information, a bit like trying to explain to someone who doesn’t use Unreal Engine how to create a material. Without the background info and basic understanding of it, the meaning of terms and such is easily lost in the attempt. I was saying it for the sake of referencing so it’s easier to search for information about it and solve that problem, but it’s great it was a simple change of the project setting.

Hello, nice to found the thread. By discovering the issue first I thought I miss something, but I tested many more hours know. I tried different monitors and different PCs. I have a problem very similar to the Thread-Starter / OP, but not 100% the same.

First, I tried “In Project Settings->Rendering there’s an option ‘Frame Buffer Pixel Format’” like OP did, but I do not really seeing changing result. @ColdBeamGames: Are you still sure it was that settings as root cause? Or perhaps did you also changed resolution or something else?

My problem is more like this one:
https://answers.unrealengine.com/questions/940909/why-is-my-game-too-bright-after-packaging-not-a-po.html

But it is not related to “packaging”. I think it is missleading, because “fullscreen” most people will try in packaged version. But the real problem on my end is running it in full screen with Full hd. I found several threads about some “kicking in gamma correction” on full screen, but still I am not sure what is the root cause of this.
In my case, running the game in Fullscreen, kick in gamma correction and make whole game more bright. It starts in Intro/Menu.

I know it’s gamma because I can’t compensate it with setting brightness lower. I have light grey background stripes in my menu, barely visible normally. Some background image noise. And when setting the game to Fullscreen, brightness/gamma kicks in and makes background noise grey stripes much better visible. Also the gameplay of course is more bright and black is “washed out”. Same as this guy explained here: Why is my game too bright after packaging? (not a Post Process issue) - UE4 AnswerHub

Same as the OP here, I can influence the “kicked in gamma” by change from fullscreen to “windowed” or “borderless windows / windowed fullscreen”. If I change that, immediately my menu and game gets darker again.

Of course I have updated driver. I have not installed any 3rd Party gamma/brightness correction software. I never touched any settings in Nvidia Controll panel. I have not installed nvidia experience. I also watched if something changed in Nvidia Controll regardless to colors settings by watching Nvidia Controll on 2nd monitor while starting the game and switching windowed modes, but nothing changed their.

**I have a big problem with the actual situation. Because some player also got feedback about “washed out” black. It’s hard enough to deal with different monitor brightness, but this gamma correction now kicks-in for some configurations and on some not is even more worse!
@
presto423 and @ColdBeamGames: Do you have any more ideas what this “kicking in gamma” could the root cause and how I can make it that no gamma correction kicks in regarless of resolution/windowed mode, etc?

  • Or any Idea how to “debug” / “monitor” to get the root cause of this different brightness/Gamma effects?

Thanks a lot**

Tried and searched for solution some more hours. Heading back to https://answers.unrealengine.com/que…-not-a-po.html who said problems are older driver. I checked again my driver, windows says geforce driver is up to date, but checking date shows it’s not. Windows 10 auto update geforce driver seems to work fine on my surface book, but not for my 2nd notebook. I updated driver by hand shows, yes, really(!), the reason was a older NVIDIA driver!

So, when people come to you or someone else found this thread people talk about “washed out black” or everything is “too bright”, just let them check geforce driver. It seems some older versions do some “gamma kick up” in fullscreen on Full HD, perhaps it was a feature for better watching movies, I don’t know.
After updating driver, I do not recognized the gamma kick in anymore. Not on packaged steam game and not in stand alone game.

@TheFlow3k Well I’m glad you fixed the problem. I also updated my drivers, but the cause was definitely related to the pixel buffer format. I tried it a number of times on different monitors and different settings. Seems there are a number of different causes for this.