Download

Full Screen FPS limit at 60?

HI All,

For today’s set of inexplicable problems:
Windowed mode, 120FPS+, turn Vsync on and get 60FPS (on a 60ghz screen) as expected.
Full-screen mode (as soon as you F11) limits out a t 60FPS.

Any idea white? I have settings in project settings set to unbound (as evidence by the fact windowed mode works faster).
Nothing but main character and an empty level with directional light. so the FPS should be running around 100 or so (this is at 4k res).

I’m trying to benchmark stuff, and this issue is making it quite impossible. Any idea where/what (perhaps an INI) I need to edit to get the full screen FPS to be unlimited as well?

I also have
bSmoothFrameRate=False
Nothing changes with
bSmoothFrameRate=True.

BTW, if I
r.SetRes 3840x2160f
I get an FPS of 100+

IF I hit F11 for fullscreen after that, the game crashes out



LogPlayLevel:  at D:/Build/++UE4/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Viewport.cpp:368
LogPlayLevel:  with error DXGI_ERROR_INVALID_CALL
LogPlayLevel: Warning: [2019.11.12-05.25.33:960][166]LogWindows: Warning: CreateProc failed: The system cannot find the file specified. (0x00000002)
....
Level: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error: begin: stack for UAT
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error: === Critical error: ===
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error:
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error: Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp] [Line: 836]
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error: Rendering thread exception:
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error: Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Util.cpp] [Line: 249]
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error: Result failed
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error:  at D:/Build/++UE4/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Viewport.cpp:368
LogPlayLevel: Error: [2019.11.12-05.25.33:960][166]LogWindows: Error:  with error DXGI_ERROR_INVALID_CALL

Etc.


This may actually end up being a bug.

For now i’m getting around all of this via BeginPlay

I would still like to know why fullscreen limits out the frames to 60… thanks.

Has no-one else experienced this yet?

It is a huge resolution, you maybe run out either texture or ram limits of old gpu, or simply the shader effects overwhelm the rendering. Turn off things like ambient occlusion, shadows, fog, things that have a potentially negative impact on rendering speed. That way you can get decent fps in fullscreen too hoepfully. Update drivers, among other recommendations can be found on forums and answerhub must be followed. Check with stat rhi and make sure draw calls are low as possible (around a thousand or less). stat gpu can give you some more timings of effects. New features might be broken, try using older stuff to avoid crash. Not a guarantee but worth investigating which is the cause of the crash. Always test in standalone mode and minimize editor to not interfering with timings. Sometimes restart editor because hitting ram limits of pc is another source of random crash.

Be more descriptive about engine version, computer specs etc. Without is difficult to give more than a few vague recommendations :slight_smile:

Fair, but i7 9700k, 64GB of ram. And an older 1080tix which it think is 12GB.
Drivers are the latest. The RTX pc I used for testing also had this issue with fullscreen being limited at 60fps.

Engine version is 4.23, updated yesterday or the day before I think.

The level setup is pretty basic. As I’m using the setup to test performance of the grass/landscape material.
I need to get a base idea of how much stuff I can push on screen to get 60fps at 4k. (And so far, it seems the only way is to go into forward shading).
Anyway, directional light, skypshere, reflection capture. And I did remove volumetric fog and even the PP…

But again. The issue here is the fact the editor goes into a lock when you fullscreen. Not my performance…

PP has default settings always enabled, you must manually disable them either from project settings or override and set to 0 some values they usually disable the effect too. SS effects such as AO, TAA, motion blur etc are all bad for high res. Check with stats to make sure your scene is budget friendly. forward shading probably a good idea, works out for vr too. I haven’t experience fps lock on full screen with r.SetRes 3840x2160f i get around 80fps with my 1070 model. After disable some PP effects as well as raytracing stuff i get 180fps. Under similar conditions the r.setres 7680x4320f gives me about 45 fps. Tho i have use the default basic scene with floor and sky only, but you can see it’s rather unlikely your scene is frame rate locked. I was run in standalone mode, not cooked.

Hit F11 to go into fool screen mode after stat FPS.
In my case (I’m using the node setup), it jumps down to 60fps immediately.
Will add a short capture to demonstrate shortly.
https://youtu.be/Bf25bVRzQDU

Try the command t.maxfps 120 or a higher number of your preference. Also, go in project settings and disable the PP effects because they fry your vga card. You must understand they are obscenely expensive to calculate on high res, never meant to use. Also i have found in 4.23 you can add a PP to the scene and switch raytracing off for reflections and AO, so just do it.

Reenabling the PP settings one by one shall reveal you the choking point where fps starts drop significantly.