Download

Frustum culling causes lit area to go dark in view

Hi!
I have placed numerous lantern blueprints with a flame particle effect with an emissive light. When the lantern is outside the camera view - I’m guessing - it’s culled. The attached light emitter is also culled which causes the lit area to visibly go dark.

Is there any way I can counter this issue? Can I disable frustum culling for certain objects?

Thanks!

You need to increase the bounds of the particle by the sounds of it. I would open up the particle and check ‘Use Fixed Bounds’ - then set them manually. You also save a bit of CPU overhead by doing this too, since it doesn’t recalculate the bounds every frame.

Protip: you should do this for all particle systems where possible, and definitely do it for GPU particles. :slight_smile: