Fresnel weird behaviour Bug?


VertexNormalWS dot CameraVectorWS:

Fresnel doesn’t output the expected behaviour in 4.13

Can you post a pic of your material setup?

Of course

As I said: If I use VertexNormalWS dot CameraVectorWS, it works as intended.

Looks like your normal textures are not actually normal maps. That means they won’t be pointing in the default vertex normal direction which is skewing your results. You need to actual use normal maps there.

If you really want these default textures in your normals, you can keep them from affecting the fresnel by plugging in VertexNormalWS to the fresnel normal input. That will override your incorrect normals.

Still doesn’t work…

BlendAngleCorrectedNormals doesn’t help either.

Thats not something I suggested.

The normal maps are in tangent space and the fresnel node expects world space. You should just leave it disconnected and the material will transform the normals into worldspace internally and the fresnel node will use that. I only suggested plugging in VertexNormalWS into fresnel if you didn’t want to change the “normalmap” textures.

it works now. I only needed the Normal input for the Base Colour :slight_smile:
Thank you.