Freeze at 75% when importing FBX

Hi there,

I recently installed UE4. This is my first time using it. I am 3D artist on this project and need to use it to import and check models before implementation, but whenever I try to import an FBX file the program freezes at 75%. It does this regardless of size, complexity, or source of the model in question. I have tried updating my drivers and reinstalling UE4 entirely, but neither have fixed the issue, nor has trying it in a different project.

My computer is a brand new msi ge62 2qd apache laptop with no other issues. I have no other ideas about what could cause this.

Hi Alice,

When importing some meshes, depending on the complexity of the mesh and the number of pieces it has, there can sometime be a wait for it to import like this. Typically the editor has not frozen to the point it will not recover, it can just take a while for the process to finish.

You can test this by disabling the option for combine meshes in the import options. Often what can happen is when the mesh is being imported with a bunch of pieces or complex geometry it will need to be triangulated, and then each piece will be saved to memory. Once a piece is saved to memory, the next piece will go through the same process and then saved to first one that was put into memory.

When you uncheck the combine meshes option you should see that everything imports rather quickly, because it doesn’t have to go through this process. If that’s not the case, let me know as it may just be something with the mesh itself rather than the import process.

Let me know.


Hey Alice,

See if you’re using FBX2016 when exporting. If you do, then set it to FBX2014/2015. That worked for me, as it freezed exactly at 75% too.

Cheers and hope it solves your problem!

I don’t believe the source of the problem lies with the mesh. I tried importing a few test meshes, including a simple cube and a number of older works of mine, but the freeze still happened. I don’t think it’s the source either, as I also tried a few random meshes I downloaded just to be certain.

At one point I walked away and let my laptop figure things out for a few hours, but upon returning nothing had changed; I don’t believe waiting longer would help much. I tried most of these things a few days ago when I first tried to google this problem, as I found a few threads of people with similar issues.

The only proposed solution I found that I have been unable to try so far is, as you say, to change some import options; I am however never given an opportunity to change any settings when I try to import something? I am not sure where the options are supposed to be.

I think I came across your post yesterday when I googled this issue! I tried that, but I was exporting as 2014/2015 from the start. Just to be safe I tried 2013 and 2012 too, but none of those worked either. I was really excited, too; I thought I’d finally come across the solution.

Thank you though!

Do you see this window when Importing a mesh?

If so, the advanced rollout (small down arrow under Auto Generate Collision) will expose the other options.

If not, Can you post a screen shot of the import options window that you see?

I never get to that window. This is as far as I get:

That’s extremely odd. I seem to recall a user having this issue a while back, but I can’t recall if it was resolved or if it was project specific. I was never able to reproduce it on my end though.

Is this only happening in this project, or is this with any project that you have?

If it’s just this project, can you try deleting/moving the Saved and Intermediate Folders from your project folder.

It is happening regardless of project, sadly. I am going to try installing UE4 on my old laptop, see if it works there, so I can at least do something, even if having to switch between laptops all the time will get annoying fast.

Do you have an older version of UE4 installed. Maybe 4.8, or try re-installing 4.9.

Can you also link your DxDiag here for reference. Again, if I recall correctly this was happening on Windows 10 for the user, but not when they had Windows 7 installed.

Uninstalling that MSI audio software resolved this issue for me as well … so weird!

That… did actually fix it. Huh. How in the world did you find that out?

i have a msi and it has the same problem, what is the name of the software that you uninstall to fix the problem? , realtek audio? nahimic?

For me what fixed this issue was to choose a specific frame range, because if I didn’t it would try to import roughly 2,000,000 (2 million) keyframes.

My 2 cents

+1 bump on this having worked for me
re Dav: Yes, Nahimic was the software I needed to remove. Uninstalled it, restarted, and imports worked fine. Thanks, w4ffles!

I also have the same problem. All FBX files regardless of complexity or size freeze at 75%. From 0% to 75% it takes 1 second and then it freezes. I have to kill the editor in TaskManager. I use Win7 and Version 4.13.0 (freshly installed). Is there a fix yet? I don’t want to uninstall my MSI Audio if this is really the cause.

…same here! Crashes all the time and I have no MSI audio running :frowning:

I had this same problem, thats why I’m on here now. But my fix was, during export of my mesh from blender, I didn’t select selection only. So I guess it was having a hard time importing the lamp, mesh, blah blah blah…but after i selected that, worked just fine.

Hello Tim,

making similar observations (slow import times) with FBX files and trying to understand this more. This time from a hardware point of view:

When the engine works on importing complex meshes and doing all that is required in the process, what hardware resources have an influence on the speed? Looking at the Windows performance monitor during the import shows CPU 15%, Memory 50% (15GB), disks idle. Why are the available resources not used more heavily?

UPDATE: CPU “usage” was at 15%, but “maximum frequency” was constant on 86% during the import, then somewhere around 30% after import was finished. Could this be it?