Framerate drops and graphics driver errors after hot compile while using SteamVR

After I do an editor recompile, I’ve noticed a lot of random editor shut downs and bugs while using SteamVR. They usually culminate in the engine shutting down, but sometimes, they even cause my monitor to turn black, meaning there’s some kind of driver issue with the graphics card I guess. I’m running the HTC Vive on a GTX 1080 with up to date drivers on the new windows 10 1607 build.
After recompiling from the editor, changing any blueprint values, or really doing much of anything causes issues, including working on material graphs. But the most frustrating part, is that the FPS while in the headset drops to below 10, while the in editor FPS seems normal still.

I wonder if my issues are similar. I can launch VR Preview once and that’s it. After that, my headset becomes unresponsive (display is stuck, no tracking, etc.). I have to close SteamVR (which also means closing UE4).

This only started happening after my computer updated to Windows 10 Anniversary Edition. Unfortunately it happens on two different machines with two different headsets. I’ve tried uninstalling/reinstalling my graphics drivers and the Vive. Still no luck!

I think you may be onto something here. I only noticed these problems after the windows anniversary update also.

Have you had any luck with this? I’ve noticed I even have problems with released UE4 games, like Brookhaven Experiment.

The only clue I’ve found is that I can restart VR Compositer rather than all of Steam VR. It’s not perfect, but it at least means I’m not also having to restart UE4 every few minutes.

I still haven’t found a true solution, and I’m starting to think the problem might be on Steam’s end.