FPS Shooter Game Sample Bots Problem

Hi, so I don’t know anything about C++ but I made an extra level for the Shooter Game Sample and whenever the match starts the bots are always spawning behind me instead of being distributed all over the map and the worst part is that some of them are even floating in the air. Does anyone know how to fix this?

You could cycle through all the bots and use the SetActorLocation node to set each one to a predetermined X,Y,Z spawn location (that should probably be individually set for each level).

If you want to prevent them from spawning above you you should ensure that the Z value for every spawn point to be at the same level as the player controller Z.

SetActorLocation API Reference: AActor::SetActorLocation | Unreal Engine Documentation

You should add AShooterTeamStart actors to the level and define if bots can spawn on those positions (parameter of the actor)

Thanks! I added more ShooterTeamStart actors and now they spawn normally all over the map… The only problem now Is that I was testing the game again and I was honestly having fun but then I noticed that some of the bots don’t really do anything, they barely move or attack… they just stand there. This is kinda weird because all the bots are the same I don’t know why some of them move and attack while others just stay in Place… Do you know what the problem is or how to fix it?

Thanks! I set the Global Gravity Z to -2000 and I think that’s what fixed it.

You need to add a NavMeshBounds volume to your level. Once you’ve placed it (basically just make sure the box covers the entire level) press P in the viewport to show the navmesh (green).