FPS Drop Between Ue4 and Ue5

yeah bro i was also having the same fps drop between ue4 and ue5

If you want to match the performance of UE4 in UE5 you’ll need to change a couple of settings to rollback the new (and more costly) rendering techniques.

Under Project Settings -> Rendering change the following:

  • Dynamic Global Illumination Method: None (instead of Lumen)
  • Reflection Method: Screen Space (instead of Lumen)
  • Shadow Map Method: Shadow Maps (instead of Virtual Shadow Maps (Beta))
  • Temporal Upsampling: Off
  • Temporal Super Resolution: Off

Under [/Script/Engine.RendererSettings] in DefaultEngine.ini add the following:

  • r.Nanite=False

With these changes the rendering and performance in UE5 should match what you would expect from UE4.

23 Likes

My issue is, UE5 Blank project running at 120fps but my GPU is constantly taxed at 100%. Any empty Viewport that throttles my GPU at a constant 100%.

So far the only conclusion I’ve come up with is the heavy Lighting is causing the high GPU usage. A 'Unlit" Viewport pushes my GPU back to normal (60% usage)

I get 120 FPS (Capped) in a 4.26 blank project. I get around 45 FPS in a UE5 blank project.

So you are just basically running ue4.26 with new UI if you don’t use any of the new rendering features

3 Likes

There is one more project setting that affects performance that is enabled by default in UE5 but not in UE4: Generate Mesh Distance Fields

1 Like

Thanks! Disabling those Real-time Rendering settings worked. My GPU load is back to running at a normal level of 60-70% (i.e: not throttling at a constant 100%) and I’m getting 120FPS in the Viewport.

It’s nice to see performance is back but I’m dishearten knowing that this new Real-time Rendering technology is extremely heavy and unusable in a practical game development setting.

What @BartShoot said, UE5 is basically 4.26 with a new UI and a new Renderer developers are unable to use. I have a clue the new Renderer was created for the film industry but it still would have been nice to use in game development. But as I see it, that feature will be turned OFF until it’s “game ready”, if ever.

1 Like

I haven’t seen this mentioned here:

Setting screen percentage to 50 (half-res) doubles my performance (~30fps → 60fps) while still keeping it sharp because of the temporal upsampling. It does have more artifacts and is noisier than full-res, but it looks pretty similar and I can run it a 60fps now.

Yes, but for me at least, having Temporal Super Resolution enabled with ScreenPercentage at >80% gives worse performance than turning Temporal Super Resolution off.

So the default of having it enabled and ScreenPercentage at 100 is just throwing performance away.

Look, I don’t want to be that guy, but someone needs to. This is a beta of a game engine that is not planned for release for at least a year still, with not one, but two extremely new technologies that single handedly change the current landscape of realtime graphics.

Why would anyone expect it to offer better, or even the same performance as a release version with technologies that are tested by the community and improved upon for years?

They said in the demo argument… I’m pretty sure they meant the actual release, not the first draft of a public beta (remember, betas are for TESTING and finding problems, not expecting that no problems will exist.)

But if I remove lumen and nanite it’s a prettier UE4. No it’s not. It’s expected to be buggy and also adds a ton of new features like animation and audio.

Disappointed about the new tech being heavy? First off, it’s new tech and it’s beta, aka not optimized, see the paragraphs above. Second, even optimized I highly doubt it’ll have the same or better performance than current and tested and optimized RTR tech. Point is to make it cheaper than hardware rendering through RTX. And I’m pretty sure it already is to a degree, considering it runs (however slow) on hardware that RTX simply can’t.

It’s one thing to report things like those issues, another to expect it to already be optimized. I’d understand those arguments if EPIC was saying it’s safe to transfer over. But they clearly say it’s NOT ready for production.

11 Likes

I notice that my both coolers from gpu working for now, before on ue4 memory from card was not used too much when I drop around 180fps at my project and in this case my VRAM was used as well, now at ue5 it get more memory from gpu instead vram interesting.

Thanks for the intel. For those who say that disabling all of this stuff is basically 4.26, keep in mind that there are new features aside from the rendering stuff.

i can’t change those values. the checkboxes are selected (true) but don’t allow clicking. what should i do?

[edit]

i figured out i could disable those properties in /Script/Engine.RendererSettings:

  • r.TemporalAA.Upsampling=False
  • r.TemporalAA.Algorithm=False

i’ve made all of the changes you recommended and FPS Drop Between Ue4 and Ue5 - #29 by Greendale_AB too, but my fps is still 3-5fps. i’m using linux but fwiw windows on the same hardware runs fast and smooth. system specs in my about me if you click on my avatar

does anyone have other ideas for fixing perf?

[edit 2]

i updated the nvidia driver to the latest available (460.73.01) and with none of the performance settings changes above, meaning default project settings, the fps is back to fast and smooth! it also fixed the visual quirk in this pic.

I’m not using Linux, or in the first place have UE5 installed at the moment. I need to free up some space for it first, plus my laptop is far lower than minimum specs for the demo.

I just wanted to ask, is there any official statement about the state of UE5 on Linux? Maybe it’s not yet compatible, even if it can be built for it? I honestly don’t know and haven’t seen anything one way or the other, but your system specs should handle way above 3-5 fps. Especially with the changes you made.

Considering you mentioned that on the same system on windows it runs well, maybe it’s a temporary OS incompatibility?

ya linux is obviously not a tier 1 platform for epic so it makes sense it lags in perf and optimization will come later.

such a big drop that makes it unusable for continuing to learn is what i’m trying to find a workaround for because i have good momentum going and i’m having fun.

other related topics i’ve started are Ue5 game dev on linux? and Understanding how linux fits in

[edit]

resolved!

Lol are you completely daft?
Rendering at 50% the size obviously renders 50% faster.

Surely you can’t be serious… XD
.

i also faced a problem of 120 FPS in UE4 and then 50 to 60 FPS i UE5

yeah bro i was have around 160 to 180 FPS in UE 4.26.2 and in UE 5 i am have max of 60 FPS

Yes, I’m serous. Epic intends to use temporal upscaling (which is why I mentioned it):

Temporal Super Resolution has the following properties:

  • Output approaching the quality of native 4k renders at input resolutions as low as 1080p, allowing for both higher framerates and better rendering fidelity.

Lumen relies heavily on Unreal Engine 4’s Temporal Upsampling with the new UE5 Temporal Super Resolution algorithm for 4k output.

For comparison purposes, the following GPU timings were taken from the PlayStation 5 Unreal Engine 5 technical demo Lumen in the Land of Nanite:

  • Average render resolution of 1400p temporally upsampled to 4K.
2 Likes

That fixed it for me :smiley: thanks