Download

For ios packaging 4.4.0

I’m trying from 1 days for packaging ios game in UE version 4.4.0 ,I made allthings in the ios quick start document page but editor gave everytime “missing certificate and mobile provision message” to me.please a answer for wrongs.

In order to package an app to run on iOS, you need to have an Apple Developer Certificate installed on your computer. And you also need to have a mobile provision profile (which you can create and download in Apple’s iOS Developer Portal) placed in the Build/IOS folder within your project folder. If those two things aren’t done, then you can’t build for iOS.

how do i “you need to have an Apple Developer Certificate installed on your computer” , please tell me, because i made all steps from ios packaging documents,everthings ,but i didn’t read this.

Maybe this helps you too?

https://docs.unrealengine.com/latest/INT/Platforms/iOS/GettingStarted/index.html

Have you red the right documentation?

I recommend reading through Apple’s App Distribution Guide, as it talks about everything from enrolling as an iOS Developer through getting an app on a device. https://developer.apple.com/library/ios/documentation/IDEs/Conceptual/AppDistributionGuide/Introduction/Introduction.html

Some of it is a little different, as parts of what that document talks about as being automated in Xcode are done by the Unreal Editor when making an Unreal Engine 4 game; but between the information on the Apple App Distribution Guide and in the Unreal Engine documentation here: https://docs.unrealengine.com/latest/INT/Platforms/iOS/GettingStarted/index.html ; that should cover most questions.

dear friends,i’m old user for UDK and unreal engine,i made everything and i did read every documents for this event.and i did test on 2 different computer ,But everytime unreal engine gave “missing certificate and mobile provision” message to me.may be iphonepackager have a bug.

If you think it’s a bug, go to answer hub and do a report:

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

Can you provide some more information on exactly what steps you performed and how you set up your App ID (explicit vs wildcard)? The steps in the quick start should work, but it’s a pretty narrow path right now where lots of things can go wrong along the way unfortunately.

hi dear jeff Wilson,

i made all things step by step in yours ios quick start and other documents.
(i installed iTunes from Apple,after i did Select from iphone packager, the New User tab and made certificate request and a key pair.after i made ios development certificate after add my devices and created app id after i did set the Bundle Identifier in my project settings in Unreal Editor (Edit > Project Settings > IOS) to match the explicit App ID. after i created own mobile provisioning profile and install it after import my mobile provisions to iphone packager etc … )

but select the ios packaging everytime " missing certificate and mobile provision" message come.i’m thinking iphone packager 4.4.0 have a bug.

and dear jeff ,i work verymuch time with UDK and unreal fronted and apple developer profiles :slight_smile: for made my own ios game "TOUGH GUYS TOURNAMENT " on the store

thanks
serhat

Same thing for me. I had it working with 4.3 and but can’t get it to work with 4.4. I used the iphone packager to reimport the certificate and provision and they get checkmarks next to them but launching to ios brings up a message about missing certificate or provision. I’ll probably post to answer hub later.

I believe you are experiencing a bug one of our satellite offices has been seeing, but we haven’t seen onsite. I’m working with them to track down the problem. It seems the validation is working outside of the editor, but not from within the editor for some setups. I haven’t been able to narrow it down yet, but hopefully I will have a solution to the problem tomorrow.

In the mean time, it seems to continue to work if you utilize the Game Launcher. The Game Launcher is an experimental feature in the editor and can be enabled in the Editor Settings under experimental. It will then show up in the Windows menu as Game Launcher. Opening that window, utilize the Advanced button, create a profile (select the + next to the drop down). Select your project. Select Cook by the Book for the Cook setting. Select IOS for the platform and your map for cooking. Then select the Package locally setting and leave all of the settings in that section blank. Hit Launch and it should cook your game and make an IPA in the Game/Binaries/IOS directory. That should at least get you running again until I can resolve the bug.

-Pete

Does the binary version of UE4 support packaging code based projects yet?

I’m getting the Missing Certificate and Mobile Provision error too, when trying to Launch or Package for iOS from Windows. When I try to import the wildcard mobile provisioning profile and the development certificate and key (previously exported from Keychain on OS X into a .p12 file) with the iPhonePackager.exe tool, nothing happens. The green checkmarks do not appear. I also tried to copy the *.mobileprovision and *.p12 files into my project’s Build/IOS folder, but still get the same error.

This is a completely clean test project, created today with the 4.4 binary version of the editor. My profiles and certificates are not expired and I can use them for regular iOS/Xcode development.

EDIT:
I’m not sure if this is relevant, but when I try to import a mobile provision, I get this message:
C:\Program Files\Unreal Engine\4.4\Engine\Binaries\DotNET\IOS\Resources\IOS already contains a development mobile provision file. Do you want to replace the provision ‘My Development Provisioning Profile’ with ‘My Development Provisioning Profile’?

The path mentioned doesn’t even exist though. I have C:\Program Files\Unreal Engine\4.4\Engine\Binaries\DotNET\IOS, but there is no Resources folder in it.

hi dear pete ,

i made your all orders but i didn’t package my Project. UE 4.4.0 gave “Autamation tool error” to me. I did try on 2 different computer win8 and win7 computers and repeatly i did read all documents and i did uninstall everything after reinstall 4.4.0 and 4.3.1 after repeatly try to package but everytime same error gave to me .i didn’t give in :slight_smile:
after i did try my macbook pro computer for pacakge to ios, install 4.4.0 and 4.3.1 to macbook after i made all document orders for mac but UE 4.4.0 and 4.3.1 gave same error to me. :slight_smile:

i did package game very easy to android but ios very very very bad and still waiting for different idea for package

serhat

serhatuzner,

Can you start an Answerhub ticket and add your log file with the failure? You can save the log from the Game Launcher via the Save Log button on the progress page. Also, I found the error with the provision not found dialog always coming up. The path for the project was not properly scoped with quotes and so the space in the path was causing issues. That fix will be in the forthcoming hot fix.

-Pete

Awdogsgo2heaven,

Not yet. It probably won’t happen for 4.5 either, but hopefully soon after that.

-Pete

I can package code projects on Windows using the Game Launcher in the github 4.4 version, but I found a few issues:

  1. The editor writes to Info.plist in the Build/IOS folder but the iPhonePackager reads from <ProjectName>-Info.plist, so I had to rename the file
  2. The Info.plist written by the editor is a UTF-8 file with BOM, which crashes the iPhonePackager XML parser. I had to use Notepad++ to convert it to a UTF-8 file without BOM.
  3. Had to copy my provisioning profile to Build/IOS and rename it to <ProjectName>.mobileprovision

That aside, the Game Launcher is much better than the “launch” because I can skip compilation completely (which is done on a remote Mac using the UnrealBuildTool) if I need. It’s just a shame the cook-on-the-fly isn’t working because that would tremendously increase my productivity, since I could skip building entirely when changing blueprints and assets.

#1 is fixed in the forthcoming hot fix. I’ll get a fix in for #2 shortly, although that shouldn’t have been a problem as it has worked here, but I’ll verify. #3 is correct for now. In 4.5 we are hoping to add a better UI in the editor to install the provisions instead of putting them in the builds folder.

-Pete

hi dear friends ,

sorry for delay ,

i did update engine 4.4.0 to 4.4.1 but nothings change. game luncher and packaging ios and on the mac package everytime give this error "MainFrameActions: Packaging (iOS): Program.Main: ERROR: ‘c:\program files\unreal engine\4.4\engine\ıntermediate\uat\ıos\ue4commandline.txt’ "
8dabbefa94291cd375bef82a9097a07b31177348.png