Foliage Tool LOD

I’ve imported a very simple static mesh into Unreal 4 for setup with the foliage tool. I then imported LOD1. Both LODs only have Element 0 underneath them. When I drop the static mesh into the world, the LODs work perfectly fine. I took this static mesh and applied it with the foliage tool. When applied with the foliage tool, none of the mesh LODs work at all. Does anyone have any solution to this problem, or should I just place every single foliage mesh manually?

Take a look at this thread: Foliage brush and LOD meshes - Content Creation - Unreal Engine Forums

Hey fighter, I had already taken a look at that thread. I did exactly as he did, import base mesh and then add LODs separately. I am still getting the issue with LODs not applying to the mesh at all when painting them using the foliage tool. It’s as if they don’t even work currently.

I’ve been advised NOT to import the LODs separately. I’m not sure how they work as a combined file, but this was what Epic said.

In blender there is no way to combine the lod + mesh to one file -> but in 3ds max and maya you do it like that: Unreal Engine 4/3d max Tutorial: LOD (english) - YouTube

I just tested it out by importing all of the LODs at once in the same file. When I drop the static mesh, it works fine. When I paint it, it still stays at the highest level of detail.

I have found an update to this bug. If you add a large static mesh in a separate level (like a plane) and paint on it, the instances will LOD correctly. If you paint anything on the landscape, though, there will be no LODs. Perhaps this is a bug with the current landscape implementation?

Not sure if this is the magic bullet, but try setting the cull distances in the foliage tool instance settings to values other than the default 0, it could be the LOD distances are scaled to fit the cull distances. Also make sure that the cluster radius is no greater than half the size of the cull start distance.