Foliage tool crash after saving foliage tool settings

I tried to use shared settings for foliage instances, I clicked to save settings from existing instance, then applied this settings to all other static meshes in foliage list. It didn’t change a thing, then it suddenly crashed.
And now whenever I go to foliage it crashes immediately, probably because that settings file is missing. How do I recover from this? Thanks.

I was able to work around this by creating an empty level and moving all the actors into it. My crash might have been two pronged but it seemed to be triggered by saving the foliage settings. Someone in the forum mentioned a workaround for saving the settings also, I’ll see if I could find the link.

Either way I stumbled on the solution that worked for me when I decided to see if ‘Foliage’ crashed UE4 when I tried to use it on my other levels, it didn’t crash so I just moved all my actors into a new level and deleted to affected one.

Here’s the bug report I filed:

…and here’s what Ehamloptiran posted that might help you:
‘I was able to replicate the crash experienced by “Nobody”. It seems that when you save the Foliage settings, it actually doesn’t create the necessary uasset. This can be proven by locating the Foliage setting in the content browser and right clicking and clicking “Show in explorer” (It won’t show it). But if you double click it, modify it then save it, then save your map, the uasset will be created. This is a workaround to prevent it crashing and allowing you to use the foliage tool again.’

Here’s the link to that post:

Thanks for workarounds :), hope it will be fixed soon though.

Looking at the log file it does appear to be related to UE4 not creating uassets for the foliage settings, then attempting to load nonexistent files.

Hope that helped. That bug drove me mad for a few days.

The other way round is to delete models that are used in foliage (while you have other map opened), then you’ll be able to avoid crash. (but it will prompt an error that it can’t find models anymore ofc)

That makes sense. I haven’t been able to get the bug to occur lately, but I have some experiments I’d like to try today.

Hey Soulsharer. After doing a bunch of tests the workaround that worked for me was cleaning out the folder that I saved foliage settings into. It seems to have a lot to do with uasset creation errors & load errors once UE4 is closed (after creating Foliage save settings)

i don’t think this should be marked as “solved”. The bug is definitely still present in 4.2. and the only chance for me to fix this was to revert all my changes.

Hi Chrys,

I am certainly willing to help you with your issue, however I will need more information. What steps are you taking that cause this crash? Thus far saving the foliage settings does not cause a crash on my end, so if I could get exact repro steps I will hopefully be further able to assist you.