Download

Foliage Render Issue. (Could someone tell me what's up?)

Hello everyone. I’m painting foliage around my world. I’m not making this for a game just to showcase some assets I’m making. This terrain will just be a backdrop for a small scene I will put together and then render out some nice stills. Can anyone tell me how I can fix the trees that are in the distance? or at least tell me what is wrong with the trees. I have been playing with LOD settings for the individual tree assets and the culling values in the foliage editor but I still cant get the desired result. Any advice would be greatly appreciated.

Just to check with you, have you made sure the material is correctly applied/has no errors etc.

Hi Something45. No errors that I can see.

Is it a megascans tree downloaded through Bridge?

And is the tree in the foreground (with colour) the exact same asset and placed the same way as the tree in the background (white)

I downloaded the free tree assets from the epic marketplace and imported them directly into my unreal project through the epic launcher. I think they might be megascans (would issues would that raise?)

Yes all the trees were painted on using the foliage brush in the same way.

I should also mention that when the camera approaches the background trees they become like the foreground trees and vice versa

Just opened project to check and no it isn’t megascans assets.

So I have been playing around and I still haven’t found a fix. However I have learned that if I rescale the world viewer and increase the amount of pixel space on the display, bounds between detailed trees and white trees grows, so I’m guessing this is an LOD issue?

If you move the camera in and out and the trees change, it’s a LOD issue. It’s looking like you have a white material on one of your higher LODs.

Hi ClockworkOcean, Thanks. I just opened the individual tree assets that I used in the foliage editor. I inspected the LODs and they all appear as I would expect them to (No white colour). Could it have something to do with screen space value?

Sorry, what screen space value?

If they bug out as you move the camera back and forth, it is LODs.

Have tried recompiling the tree material?

Theres a slider for changing a value called screen space, it is found in the foliage editor and also in each tree asset. I wasn’t sure if it was relevant.

I have tried rebuilding the lighting in the scene only issue that flag are missing importance volumes and stuff like that. How would I go about recompiling the tree material?

I should mention that all the trees that are a funny white colour in the distance all have different materials.

The tree assets and materials I’m using came with a demo map and the issue does not happen in that map. So its level specific.

I’m assuming you’re not using static lighting? So you don’t need an importance volume.

If the same trees work in another level, I’d just remove the foliage from this one, and re-place it.

Does that work?

I have replaced the assets in the foliage editor a few times but no luck.
The trees that are in the other level were placed individually, in my level they are painted on using the foliage editor so they are grouped as one object in the world outliner, perhaps there in lies the problem?

Meh, I give up. Impossible to fix without actually seeing it.

If you can put a minimal setup in tiny project and give me a link, I’ll take a look, but…

Its a long shot but does this help:
https://answers.unrealengine.com/questions/66012/missing-texture-on-foliage.html

1 Like

Thank you to both of you, the solution was found by looking through the materials for the trees and I found a box [add emissive] it was checked, I unchecked it and presto landscape looks more like what I had hoped for. Looks like asset designer wanted an emissive layer on the higher LODs, strange. Anyway I can move forward with my project now, cheers guys.