Foliage painting not working?

Hello. I’m trying to paint some foliage into my landscape using the foliage tool, but it doesn’t do anything. I am in the correct level, I have several static meshes in the foliage tool, paint on landscape is checked, and I don’t have any large static meshes underneath the level. Foliage painting works normally on a landscape in a new level, but my level has quite a few variables and a fairly extensive blueprint; I’d really rather not have to try to port everything into a new level.

Anyway, when I hover over the landscape, the sphere where the foliage would go appears, but when I control click, nothing happens. I’m sure I’m missing something simple :confused: Thanks very much for your .

(I hope it’s ok that I’m reposting my question from AnswerHub. This has been giving me fits for weeks now.)

Can you post a picture of your settings?

-make sure that you are in the paint mode
-have you selected a mesh in the tool?
-change the density and try it again
-which engine version do you use? :slight_smile:

Sure, ,

here’s a picture of the foliage tool not working. Thanks very much for your quick reply.

Thanks for the quick reply, . I posted a screenshot of it not working above. I am indeed in paint mode, I have tried selecting both one mesh and multiple meshes in the tool, I have adjusted density to several different values, and I am using engine 4.8.2.

Oh my god. It was absolutely something simple. For those reading this, notice in my screenshot under Placement, Height the minimum is -262,144. My landscape was below this Z position for some reason, and that’s why it wasn’t painting. I set the minimum to a much lower number and now it’s working fine. , , thank you so much for your help. Posting this and looking at the screenshot finally cracked it open for me. Thanks again!

(If you don’t see Placement and all that good stuff at the bottom, make sure you’ve selected at least one static mesh by clicking on it in the foliage tool.)

1 Like

First of all not that simple. I have a rocket ship that flies up into space and lands on an asteroid that has a bunch of mushrooms all over it, and for the life of me could not get the foliage tool working. You were the only person I’ve seen point this out so thanks.

I am having the same issue and still havnt gotten it to work

f@#king unreal editor…you have to hover the folliage you want and a bloody check box will apear

got the solution for it… i was tripping and searching for hours but finally got the answer…
after placing the foliage assets in foliage tool, select all of them and then scroll down the settings of them in the foliage tool and just make sure you are under the placement values…, if not then tweak them according to your need and you will be able to place foliage. I had a outer space scene and my placement was waay less acording to my planet, so had to increase it by a ton…

Six months later… I ran into an issue with Foliage not painting, and at first I thought it was my Z offset which had negative large numbers. They came off an asset pack and not sure why you would want -100 and -50 for trees, but that was not the issue.

In my case I had accidentally set scaling so that the minimum value was 3 and the maximum value was 2 and this caused the painter to think it was painting trees, the numbers by each SMF went up, but were not being painted, at least they are not visible. Correcting this fixed the issue.

I had the same issue. I fixed it after days of research and tried everything :smiley:
I had to change the collision of the Landscape. And now it works again.
Change WorldStatic to Block.