Foliage not placing

I’d hate to be posting this, but it doesn’t seem there’s a real answer anywhere, and it’s making me rethink if I should even approach UE4. So far my experience with UE4 has been a massive headache, things don’t work, then they do, then they don’t again, for no apparent reason. It seems every solution stems from an ‘oops, it worked’ scenario.

For example, WorldMachine heightmaps resolution bug when importing a terrain. For some reason, it frequently bugs out and insists that your heightmaps are different resolutions, incompatible. Upon restarting UE4, and changing nothing about my process or height maps, it works perfectly first try. I have found no way around this aside from restarting UE4 altogether. This was the first hiccup, but a small one. I decided to hope that no other processes would be so unpredictable and gamble on continuing my project.

Now, I am just trying to place trees and grass with the foliage tool. It too, seems choppy and unpredictable.
It appears I have set everything up correctly, I even removed the water from the scene (static mesh) as it was close to the terrain and I read it can confuse foliage a bit. Still, the tool places nothing. I can manually place the trees, grass, everything. Works great. Looks neat, but I won’t be individually placing hundreds of trees.

But the foliage tool is literally not doing a thing, no matter what I do. I’ve checked all the boxes in foliage to paint on everything, reuploaded my foliage multiple times, rebuilt the foliage from the static meshes and reapplied materials, saved foliage via the foliage tool in a new directory (tried to let the foliage tool save its own version of my imported foliage, then reimport those assets into foliage) restarted UE4… Nothing.

Am I missing something here?
UE 4.14.3

3rd time typing this, sorry if I seem impatient, that would be the cause. I appreciate any help.

I just followed the tutorial included with the engine, even the static mesh of the cube provided by Epic Games will not place anywhere, which leads me to believe it is either a bug or due to my terrain…?

I remade the terrain and it fixed it.
Can anyone tell me why this could’ve happened? The problem was the terrain, but I hadn’t even edited the terrain with UE4 prior to adding trees and grass, world machine allowed me to create height maps that texture the map more naturally than I ever could, so this is really the first thing I’ve done to the terrain via the UE4 editor. All I did prior to using foliage was import the terrain…

Does this problem happen when the terrain is imported?
More importantly, can I expect this to happen down the line after investing more time into this project, resulting in a loss of data?

1 Like

I have the exact same problem. Found in this other topic that we’re not the only ones:

After I imported a terrain created in Gaea to a World Partition level that had basic terrain, I couldn’t place or delete foliage anywhere.

It broke all other levels I have in the project as well, even though they are using a different landscape. I deleted the terrain but that didn’t fix it for any level.

I’m afraid I’m gonna have to start a new project because nothing has worked so far. :smiling_face_with_tear:

Typically with unreals foliage tool you’ll run into one or two things. One being that you lower the paint density but also have lowered the plant density to a point where the probability of it spawning is so low it never does. The second instance could be that you don’t have the correct parameters such as making sure landscape is checked as a placable location for the foliage actor.

There are one off cases the actor completely breaks but that only stops you from deleting foliage and not placing it.

Check your density values across the board and start there.

1 Like