Foliage Lighting errors after upgrading from 4.4 to 4.5

We recently upgraded our project from 4.4 to 4.5

One new side effect we have noticed is errors in foliage lighting what were not present in 4.4

The foliage in the screenshots were lighting properly before we upgraded. Now you can see some strange bright clumps of foliage and some black. Level lighting setup has not changed.

Here is one example:

Anderw
Uppercut Games

Hi UppercutAJ,

Have you attempted this in 4.6? What foliage settings are you using?

Hi UppercutAJ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.
Thank you.

We have not upgraded to 4.6 yet so i can’t tell you if that fixes it.

I can also tell you that the player also goes black in the same areas the plants to, so its more likey a light proble problem or something?

We have turned off lightmass baking altogether and gone to a completely dynamic solution now, as a way to get around these problems.

Hi UppercutAJ,

There have been several adjustments to how lighting works with foliage in 4.6, specifically:

"Static Lighting on Foliage

Precomputed lighting and shadows are now supported on foliage objects and instanced meshes! This allows for very efficient rendering in scenes with Stationary or Static lights.

This Image Was Automatically Resized by using the Screenshot Tag. Click to view the full version

Static lighting is appropriate for medium sized levels but does not scale up to huge scenes in build times or memory requirements. Be sure to use very small lightmap resolutions on meshes that will be instanced many times.
"

You can find more information on changes made to the editor here:

Unreal Engine 4.6 Released! - Announcements - Unreal Engine Forums!