Foliage flickering ue5.1(5.2)

im new to UE and now playing with nanite for foliage. The problem is when I enable Nanite in StaticMesh details there starts massive flickering in leaves and grass. Without Nanite it doesnt flicker, but shadows still glitching. Probably there something like z-order or lighting. So much tweaks so i dont know what to do) By the way im working in 5.1/5.2

Update: in 5.1 shadows works good without nanite. With it there occurs flickering

Hello @Treeteey

Were you able to resolve this issue? If not, do you have two sides(Double sided) checked in the materials?

I used free asset Megascans Black Alder from epic shop. There is Two sided option in Material instances, switching that off doesnt make any difference. For grass i turned off Nanite and it looks better.
When turning Mask option (Opacity, roughness, translucency) leaves look terrible but no flickering (as shown in pic)

So here is the part of solution for that particular problem. In texture for leaves go to Level of Details → Mip Gen Settings → switch to “NoMipmaps” (also few others will help)

I had the same problem. I tried turning off the wind with BP_GlobalFoliageActor (controlling foliage), and the flickering stopped. I did want wind to work, so just removing wind didn’t solve the whole problem, since i then couldn’t use wind. I then went to the materials, for this instance SM_BlackAlder_field_01 (instance), and went into try and change the wind settings on the materials. Inside the material instance there is the setting “wind”, and after enabling “advanced wind”, in both checkboxes, all flickering stopped, and the wind was still there, and still following the BP_GlobalFoliageActor.
The flickering wasn’t only on the leafes, but also the trunk and other materials on the tree. So i just enabled the advanced wind checkboxes on all materials that were flickering, and it stopped.

2 Likes

Thats what worked for me! Thanks!

None of the previous comments on that post worked for me. I found the solution to the same problem that Treeteey has been having with the following tutorial:

https://www.youtube.com/watch?v=wVMImHI24QI

Thanks a lot, It worked!