Download

Foliage Cull distance shadow issue

I am working on a project for my design studio in UE4.26 that is viewed through top down only. I am cheating the top down with a high focal length (200+) and pulling the camera 40k+ unit away from my surface. However, when I do this any foliage that was created through painting or procedural foliage does not render out with proper detail or shadows. If I hand place the meshes they render out correctly though.
My professor and I have tried everything we can think of including:
-Baking light
-Disabling cull distance within the foliage settings
-Upping the cull distance to 500k+
-Forcing all LODs to 0
Also cast shadow, cast dynamic shadow, and cast static shadow are all on, and foliage is set to HighDetail.
My only thought is to manually place all my actors but that would very heavy and time consuming.
In the linked images the stuff circled in red are the placed actors, the blue are the foliage
Thank you for any help!


You can try to bump up mesh distance fields to an insane resolution. (If using a 3090 it won’t be an issue).
And using DFAO.
It should still cost less than cascade.

The foliage brush should have settings to control the shadow distance.
If it doesn’t.
World settings and fine-tune your cascade shadow distance.
If its not in world settings it’s on the directional light.

Ray tracing may still have issues with this.
Because the epic team is the epic team you know? Why fix stuff that’s been reported broken 2 years ago. Why fix anything at all…
Get the nvidia rtx branch and look up what r. Parameter to use to control the foliage distance.

For what it is worth.
Games don’t usually use shadows on grass.
You can fake the effect by creating an ambient occlusion like map to darken the bottom of the leaves/stem.
And you’d be hard-pressed to notice that the shadow isn’t there unless it appears for one mesh but not another - once the leaves are no longer a uniform color.

For the most part, I have cascade shadows set to a maximum of 1.5m from camera. And DFAO after.
This isn’t without issues (can’t animate dfao shadows).
Performance in .26 is trash anyway. So it’s not like anything will ever be published with it and work…

Thank you for the feedback.
I ran through those settings and while the grass does look a bit better it is still far from what I would need to present this as a project.
It seems like, as you said, the problem is mainly that grass is usually not used with shadows, and the fact that I am creating a false orthographic view. I would love to hear anymore advice on the matter, but I may have to change the premise of how my project will be view.

Ortho cameras don’t support shadows at all - they never have in unreal.

There’s about a billion posts and probably around 2b requests which is more than the user base for UE4 itself. But as I said before the epic team DGAF about their own software…
https://answers.unrealengine.com/questions/177203/shadows-not-working-in-orthographic.html

That’s probably why you have to fake the false ortho view in the first place.

There’s not many other options.

You can try screen space contact shadows but they are screen space - items not on screen won’t cast shadows. edges won’t have shadows.

You can try the grass in the landscape grass node.

Also.
If you are using baked. and you need dynamic only on grass. set up with light channels and only light the grass/landscape with the dynamic movable light.

For grass look halfway decent you have to edit the mesh and set the normals to point up.

IN most regular setups. even as foliage
you need to have the light set up to cast dynamic shadows.
in cascaded shadow maps, set
Dynamic Shadow Distance Movable Light (smaller numbers = more detail).

Without ray-tracing on I get shadows at apparently any distance.