Download

Foliage brush and LOD meshes

Hi everyone.

Ive been trying to optimise some of the meshes that we have in our game, most of which being grass.

We have come across a strange problem where the LOD doesnt transition if the meshes were placed via the foliage brush but
if they were placed individually, the LOD works fine.

Before LOD transition (Left is foliage brush, right is single placed mesh)

http://i208.photobucket.com/albums/bb217/zappy65/LOD_zps3a533b9f.jpg

After LOD transition (Left is foliage brush, right is single placed mesh)

http://i208.photobucket.com/albums/bb217/zappy65/LOD1_zps61e79e51.jpg

As you can see the mesh on the right has changed materials and (as you cant see) the mesh has greatly reduced in vertices but the very same mesh applied to the level with the foliage brush has not transitioned. These 2 instances are the exact same, only difference was how they were applied to the world.

Any knowledge on fixing this issues is appreciated.
Jon

Hi JonMeldrum,

***"LOD

Static Mesh LOD is supported on foliage. There are a few caveats:

You should ensure your Static Mesh has only one entry in the Elements array (visible under LOD0).
Note that light and shadowmaps are shared between all LOD levels, so all LODs need to use the same unwrapping.
Currently the entire cluster of instances change LODs simultaneously. We may add support for distance-based fading per instance in the future."***

This was taken from the Foliage tool documentation. This may help you.

Let me know!

Thank you!

Tim

Hi Tim,

I managed to fix the problem with a work around. Im not sure if its a bug or not so Ill explain.

Previously what I was doing was creating my high poly mesh, duplicating and making a low poly and creating an LOD group in maya and exporting in a single .FBX then importing with LOD’s. This work as I stated with single placed instanced but not with the foliage brush.

To work around what I did was imported the high poly mesh without any LOD, group etc as a single mesh in a single .FBX. I then made a seperate .FBX and imported that under import LOD of the high poly mesh in the mesh editor. For some reason this import method worked with single placement and the foliage brush.

Im not sure why the first method didnt work with the foliage brush as most of the documentation I could find suggested I use LOD groups and not single imports per LOD model. Either way its working now, could be a problem with the import method but im not sure.

Thanks for your help Tim.
Jon

Well I have similar problem in max.
LOD0 high poly model 3k
LOD1 mid poly model 2k
LOD2 plane with map
xform reset
grouped
level of detail
exported as fbx

when imported as single file on import button its ok
but when imported as scene LOD2 is transited 50 cm up or on side or little bit scaled tried everything have no idea what to do? any ideas?

Glad you’ve got it working, not sure what the issue was with importing the whole lod group in one, but personally I’ve found importing the lods individually works better for me, first you can tweak and reimport the lods individually, and second (in max anyway) creating the lod group in the first place is a bit of a convoluted process…

I had rail that is relatively complex, there is some problem in geometry so i made spline from rail, xform reset spline, then spline conveted to polygon, and make another rail xform reset, grouped, level of detail, instanced some 50 times (precise), export fbx, and import scene in UT. Works… still have no idea what is problem with first one, guess some geometry issue but they are same…