Download

Foliage Blurriness

Whenever i make foliage the materials that are using opacity textures look extremely blurry. It looks ok when the camera is right in front but when i move further away it gets blurrier and blurrier. I have posted some pictures under. The first is from my ue4. The second is a screenshot from rdr2. In the rdr2 screenshot you can see that the foliage looks extremely sharp, even the foliage that is pretty far away from the camera looks sharp. I have been stryggling with this for months and cant find a solution. If you got any tips or a fix i would appreciate it greatly!

issues.PNG.jpg

Here is the opacity texture:

Does your tree have any movement in it? Also make sure you’re on Epic or Cinematic scalability settings

Hi, i do have wind on the tree but it looks the same without it. My scalability settings is set to epic. I tried turning it to cinematic, but it looked the same.

Try enabling “Support Accurate Velocities from Vertex Deformation” in the material. You need to enable it in the Project Settings, under Rendering, and then it should be on by default in the material(s) but you can double check. That will improve TAA’s ability to resolve materials animated in the vertex shader.

You can also use a console command to reduce the number of samples TAA uses(r.TemporalAASamples) for extra clarity at the cost of more ghosting in movement, which can also be visible in RDR2. iirc Epic settings defaults it to 8 and lower reduces the flickering/blurring, but any lower than 2 and you’ll pretty much lose AA. If that works for you, you’ll need to add it engine or project-wide so it’s always enabled.

Hi, thanks for the help. I tried enabling the accurate velocities from vertex deformation but it didnt change the blurriness. I tried using a taa sample count of 4 but it still looked the same. I think the issue might have something to do with the mip maps on the texture containing the alpha map. It looks like the resolution of the alpha texture decreases really fast.

Use masked not translucent, unless your using masked, then i have no idea.

Do this. Offset the mip with a scalar parameter, it’s the bias pin.
then modify the material instance with integers -1, -2, up to something like -5 for no mipping.

Note that this will cost performance if you go too harsh. Or at the very least it will eat a chunk of space for keeping the texture in memory.
normally for character hair -5 seems to work fine, it still disappears after a certain distance - all of this obviously depends on the alpha texture.

The more detailed the texture is, the more the mip process will make it blurry.

Ps: if you figure out how to get the grass to not pop LODs like popcorn just like RDR2 does you should make a tutorial. The game is damn amazing on all accounts of detail/performance and getting ue4 to perform the same with that kind of quality seems near impossible.
I’m not even sure the grass Has LODs to be honest. The only Popping you ever see you literally have to go out of your way to experience - railroad tracks, running along you’ll see seams slightly popping. Those also show you the avg. Distance of where the LODs should pop and cause you to notice them more. So, go check it at the risk of not enjoying the game as much :stuck_out_tongue:

Ah, if it’s your mipmaps you could push back the mips like MostHost suggests or sharpen the texture mips, which is done in the texture properties directly in the engine. I forgot what the option was called by it includes 5 steps for blurring and 10 for sharpening, with the higher numbers being the strongest.