Download

Foilage subsurface scattering with raytracing shadows issue

I would use raytracing shadows in my project. But same material doesn’t shows subsurface scattering on leaves with raytracing shadows on. How to fix this?

Screenshot of leave material

I think you should turn on the raytrace option in the Texture editor

I’m 90% sure sub surf is just not supported by ray trace.

first, try not using the two sided foliage setting. Go with default lit. See if you can get sub surf to work at all when ray tracing is on.

Second, should that be working (which i don’t think it would), you need to review the two sided foliage .usf to determine why its applying the sub surface differently from the default lit shader.

Btw, you also need an opacity value to determine how the shading of the sub surf is done. Perhaps connecting the same mask texture will make it work… before you go testing the shading models… you can also set it to a default scalar value like .5.
It should not affect the transparency if using two sided foliage.

Raytraced shadows do support subsurface scattering, just enable Transmission on the light. Opacity is only used to control the self-shadow thickness when using the TwoSidedFoliage model. So it’s not *needed *but it’s helpful when trying to accurately depict thin pieces of foliage vs thicker ones.

Good to know, but last night when I tested it it was giving the exact same errors as the skeletal meshes.
the values in the opacity cut off the map you use for thickness by just enabling the sub surf when the values are greater than .011 and turns them off otherwise, preventing a smooth gradient.

You can usually test this by single UV plane and using a gradient out of the UV itself as the value for the surface thickness.

No idea on ray trace, or if the latest .26 has the same issues.