Foilage shadows issue?

Hi, I am having this issue with my foilage. The shadows only work in patches. Any way this can be fixed? Thanks.

Sort of odd, but since we don’t know what you are doing, this could be the result of using several meshes with different settings on each.
both within a grass node, or within the foliage tool.

As a general rule of thumb, grass shouldn’t cast shadows.

Hi [USER=“3140864”]MostHost LA[/USER] The grass is scattered using the foilage tool. I am using only one mesh foilage tool with one setting. The foilage instances are movable so they should cast shadows. I am thinking maybe the scale is the issue. When I increased the scale, the foilage shadows work but the scale of the grasses will look wrong in comparison with the other assets.

As I said. On grass you don’t want shadow.
unless you are rendering for a movie or something similar, a game cannot afford the cost of casting shadows on 30k tris as easily as anyone who has never made a game is lead to think.

That said,
Only thing I can think of with scale affecting shadows is DFAO. Since when you have a bigger object, the volume is also bigger, though not more detailed.

The issue could be something else entierly too, I’d start with reviewing the mesh itself, and the vertex normals on it.
then the method of painting - just use the grass node…
Then the scene’s light settings - including the contact shadows setting maybe…

The scene uses stationary sun and sky so I can’t use distandce field ao. Switched to distance field ao by using movable skylight. Did not work.
Here is how it looks with a bigger scale:

EDIT: [USER=“3140864”]MostHost LA[/USER] Seems the vertex normals were the issue. It is fixed now. Thank… Now I am having this issue:

Dark patches that move around the grass foilage in a wierd manner. Any idea what might be causing this?

Could it be the LODs?

I don’t think so. I used a foilage mesh with only one lod and the issue is still there.

Contact shadows?
whats the shader loom like? Could it be a reflection?

Found it. Turned off directional light ‘‘cast raytraced shadows’’ The issue is gone. Thanks for the suggestions, MostHost LA.