Download

Fog viewable in editor, but not in play mode?

Hey guys,

Bit of a newbie question, but perhaps we’ve missed something easy in our settings? In our editor the fog displays correctly, but when we hit ‘play’ the fog effect disappears. What have we missed? Just attached some images to show our settings and a comparison of being in the editor and being in-game:

http://s8.postimg.org/vqegjc6g1/Fog_off.png

http://s8.postimg.org/oyo1ghhgh/Fog_on.png

http://s8.postimg.org/vb36qbkip/Fog_Setting.png

Really appreciate any help guys :slight_smile:

Is it just happening in one special level or also in other ones -> like the example map? :slight_smile: What else do you have in your scene + which lights and engine version do you use?

Hey man, thanks for replying! I’m using 4.6 at the moment. Below are the light specs I’m using, which I’m fairly sure are pretty much unchanged from the default settings:



As for other levels, I’m not sure what you mean? I don’t have any other levels currently, and the example map doesn’t have the fog we put in. Currently the level is more or less a flat plane with the generic sand texture, some rocks we’ve modelled, our character, the atmospheric fog and the standard sky(altered in color) and light source.

What happens when you use such a fog setup in the example map? -> then we know if it’s a level specific problem or a general one :wink:

  • set your light to “moveable” and check what happens

Cool, thanks for elaborating… I did what you said, and changed it to moveable but didn’t notice any difference. I also added it into the example map and in play mode it works fine… I’m guessing then it must be something in my level that I’ve put in. Would a skybox affect it at all?

Edit: Nomygod. I figured out I had two skyboxes… whilst they were both exactly the same, when I deleted one, the fog became viewable in play mode… Not sure what happened there, but thanks heaps for your help, Fighter!:smiley:

I know this thread is old , but I have exactly the opposite issue. local volumetric fog does not show in the editor , but shows only when I click play . Which makes it difficult to place fog locations. any ideas? thanx , also I noticed if I use “simulate” , I can then see the fog border line, but when I move the gizmo , the fog does not move with it.

also if I want to keep the fog close to the ground , I cannot enlarge the fog actor just along the ground. if I enlarge any axis , it enlarges all axis’s. Also even when it is by the ground , as the character moves , there is a lot of up and down movement in the fog itself.

I just had this same problem and found a way to fix it, though it’s a very, very specific situation. Still, maybe this will help someone.

All my lights are currently dynamic and I have “Force No Precomputed Lighting” turned on in World Settings (I feel I should mention this is purely for the sake of iterating quickly while designing; never do this if you want your game to be performant). I have an ExponentialHeightFog actor with volumetric fog enabled.

I found that if I disabled volumetric fog, the fog showed up fine (and obviously looked completely different and awful). This clued me in to it being something in the volumetric fog settings; turns out I needed to set the emissive in the volumetric fog to something besides “black”, so I turned up the Vibrance to 0.001 and everything shows up in “Play” mode now. Very weird and specific, like I said, but there you have it.

1 Like

can someone help, press alt + f

Hi


Hi, try changing the Volumetric Fog -> Emissive Color to anything other than Black. It worked on my project.