Download

Fog and Transparency / Water Plane

HI all. Just a quick question. Using one of the sample water planes, the transparent one, and noticed that fog doesn’t seem to affect it.

Here’s what it looks like currently.

Any ideas how I could improve the look of this at all?

Something need to be done to the material itself or what? Just thought I’d ask before I did any major poking about.

Cheers all! Thanks in advance!

In material options there are option for enabling per vertex fog calculation for transparent.

Tried both on and off for that option and it doesn’t change.

Could that be something to do with it being blueprinted?

Is that mesh actually just single quad? Have you tested with other smaller objects with same material?

No its a very highly tessellated plane.

I’ve tried with my own plane mesh, as well as the plane mesh that comes with the water planes demo.

Sorry to bump. But any ideas why the fog isnt affecting the water planes?

As I said, using the transparent BP from the Water Planes Collection on the learn tab.

Are you using a separate depth pass?

Have you tried comparing your setup to the Water Examples that was released by Epic? This can be downloaded via the Learn Tab on the Launcher if you’re not aware of it.

Using exponential height fog and atmospheric fog work with that that I can see.

Try comparing the setups between the two and let us know if you’re still having trouble.

Tim

I have no idea. How can I tell?

Those are the very ones I am using XD.

Probably also worth mentioning I haven’t edited them at all.

Ever find a solution to this?

I just tried reproducing this using the same example content but I see the translucency vertex fog working as expected.

I made a new level and placed the BP and then placed both atmospheric and exponential fog separately and both worked. You can see its vertex based by the vertex interpolation issue in this image:

ahh.JPG

I can only suggest making a new test level and placing only the water BP and fog first. Then verify the vertex fog setting is correct. Then possibly try placing a regular mesh without using the BP if that still doesn’t work.

That doesnt work for me… Im using a spline to create a river.

In fact that checkbox doesnt even work on glass windows… the reflections are solid non fogged.

try using a skylight if you didn’t

Sorry for the necro… but it looks like it was never answered and searching still brings this post up.

I found something that worked well. In your Translucent Material, under the Translucency settings, be sure that Apply Fogging and Compute Fog Per Pixel are both ticked true. I did see a mild FPS hit when I did this, but it wasn’t so much as to make a huge difference. I hope this helps.

Also sorry for the necro, but I have the same problem with the Water Materials. I added the SM_Water_Plane mesh and it look ok, but the exponential heigh fog doesn’t work on it.
I tried the solution above and ticked Compute Fog Per Pixel, and it just messed up the whole material.

Turn off/on seperate translucency