Floating foliage? :I

Hello everyone,

Any ideas on how to work around this? I thought it might be because of the slope angle but i haven tthe faintest clue on how to make the grass along properly along slopes. Some slopes, the grass is painted underneath the hill so it cannot be seen :frowning: I have a couple of grass variants and I want them to blend gracefully along the slopes. Also want to make some extreme hills.

Any ideas on how to solve this?

Kind regards :slight_smile:

I think your pivot position is not in the right location, it should be in the bottom center of the grass.

  1. check for invisible collisions
  2. set your quality settings to “epic”
  3. as Roel already mentioned, take a look at the pivot :slight_smile:

Hmm, strange → which engine version do you use so that I can test it? :slight_smile: Also make sure that your collision thickness is on 16 → you can find it in the details panel of your landscape

Hey Roel, fighter5347,

Thanks for the quick replies :smiley:

I did have them at the centre but I forgot to freeze transform them ^^;

However i am still having issues…

1: The plants are going underneath the surface on some parts of the hills,
2 & 3: There is foliage here but it is beneath the surface
4: When i re-sculpt the land, the foliage pops back on top o.0

I find this kind of an issue as I prefer to sculpt my landscape in a certain way before I add foliage.
I think it is wrong that I have to ruin the surfaces just to get plants to pop back up, it doesn’t make sense to me :frowning:

Any ideas? :slight_smile:

Thanks for having a look.

hi fighter5347.

i am using 4.5.1 ^^

Just tested it and it should work without any problems → have you already “rebuild” everything? (light, geometry, path,…)

the only way i can fix it is by just adjusting the landscape. :frowning:

Btw do you know any good tutorials on trying to make my grass ‘look good’ XD

I feel they look horrible! and where do you set your quality settings to epic?

edit: found the epic quality thing XD

Cheers :slight_smile:

In this thread you can find many good ways how you can make your grass better: Nature Environment in UE4 - Asset Creation - Unreal Engine Forums Also take a look at the new foilage shading mode + I will release a free grass/vegetation pack in around 1-2 weeks. There you can also find some interesting materials [FREE] grass meshes - World Creation - Unreal Engine Forums (old thread)

thank you for the tutorials, your grass looks very pretty, pretty much the results i am trying to achieve, i am gona finish reading this stuff up and try to get similar results before trying out your material :slight_smile:

your grass renders beautifully :slight_smile: but i noticed something odd?

when you turn the camera around 360, the grass turns white, is this intended or missing something? :slight_smile:
EDIT: lol! nevermind realized it is the specularity of the sky, since the spec was flat it appears like that :slight_smile:

these are my results using the same shader setup as yours. What do you think? ;o

only thing that bugs me right now is it gets all ugly when i get further from the camera, i am supposing this has to do with quality and draw distance. Do you know what I can look at to solve this? :slight_smile:

Looks really good! With the new shader mode in 4.7 it will look even better. :smiley: I think you mean that the texture gets blurry over the distance? → play around with the mip map settings (double click on the texture - mip map) or change the texture streaming distance (https://answers.unrealengine.com/questions/25898/how-to-disable-texture-blurring-based-on-a-camera.html)

I know this is an older topic, but I was having this same issue on 4.9.0, 4.9.2, and in 4.10.0 preview 4. I can’t say about previous versions, but suspect it’s similar there as well. According to all the advice here, my settings were correct, but still I had spots where the grass was underneath the ground. I did figure out how to fix it though, so I thought I would share here. I found this post first while I was searching for info on the issue, so I suspect others may as well.

The solution I found: Select the landscape-> details → Landscape section → Collision Mip Level (right above Collision Thickness). Hovering says the smaller the number the more accurate. Default was 1, so I set it to 0. Grass now draws correctly and no longer underneath the landscape.

Hope this helps.

Thank you , that was very useful information.

I’m now in UE5.0EA and this solution works wonderful still. Thank you for this solution. Commenting so people know: you can change the collision mip level to any value and then back again and it still will be fixed, I guess it just updates foliage whenever you adjust that value.