Flickering on glass shader etc

Hi,
I’ve been having this issue for a while now, trying to google my way out of this, but I’m at the end of my rope, so here goes.

I have a lot of flickering on my glass shaders, and when there’s some noticeable bloom. (see gif links). Particularly on all SSR reflections?
You can clearly see the issue on these gifs, and it’s stopping me from finishing my scenes properly.

[gif1][1]
[gif2][2]
[gif3][3]

Currently my setup looks like this:

  • Temporal AA
  • Circle DOF
  • Transparent shader with Fresnel
  • tried several r.ssr.Quality settings, flickering never goes away.
  • The flickering is also visible when looking at a directional light with light shafts enabled and some bloom
  • Same in 4.9 and later 4.11

Below is my glass shader and DOF settings, but I’ve tweaked these all to no end, and the flickering is still there. This also happens on other machines and in packages…
So I’ve tried a lot, someone got any ideas?

:frowning:

91038-circledof.png

I see flickering in the gifs even on non-glass (like the pillows). Is this compression artifacting or is it also flickering in game?

Are you using any post process material Blendables?

I’m not using any post process blendables.
The flickering on the cushions probably IS compression, but the flickering on the floor is present in the scene with the lamp, and the couch is flickering in the 3rd one too (moire should only flicker when you move right?)

It’s also a little visible at the end of the hallway in the first gif, where the bloom overlaps part of the mesh. Even packaged builds. So maybe my question was wrongly formulated, my apologies.

this is a rough one without looking at the assets. My approach would be to simplify everything by removing a peice on at a time.

Simplify the material a step at a time. Remove refraction, then plug simple roughness constant, then simple color constant, etc.

Then if still visible remove each post process one at a time.

Once you find the things that exacerbate the issue then you can have info on reproducing it easily for others to help test.

That being said, one thing to try. I know you get some artifacting with high quality levels of SSR. Can you try setting the quality to 50 and see if it goes away?

So I’ve tried both approaches. Delete all post process volumes, then added a new one and played with the quality slider.

Also made a new material with one const3 input for the color and 1 const input for the roughness and I still found a case where the flickering occurs (see this gif)

it’s less obvious with low SSR quality and high roughness, but there’s still cases to be found. Any ideas?

gif example
just for clarification purposes, this whole shot seems jittery. Even the lens flare flickers sometimes. No succes so far on any of the proposed methods.

sorry to spam my own thread:
[another GIF][1]
I’ve created an empty new project and made a cube with the material on it, still flickery… Is there an SSR bug? Standard Glass material from starter content has the same flickering if you enable SSR and crank up the metallic value.

unfortunately no, not yet.
There are still multiple instances of this occurring throughout big scenes.
SSR at big distances seem to worsen it.

Hello guys,

I have the same flickering. did you find a solution for it?

best T.