Flickering mesh


when i play my game some meshes are flickering more like it go invisible and back visible how to fix that?

Thanks in advance,


Select your mesh. Or if it’s a component in a BP select that. Go to the details panel and look for the render tab. Find the “bounds” setting. Turn it up a bit. :slight_smile:

Hope that works! Good luck!


thanks it works

Been looking for a solution for some time on this. Setting a higher bounds value works great:)

1 Like

Thank you so much ive been going down the zfighting road and was glad to see it had nothing to do with that. I had changed nearclip plane, didn’t work, I changed models thickness that did nothing. bounds worked perfectly. you rock.

Try to delete all collider on your physic skeleton

Instead of deleting all physics bodies, I found that aligning them properly did the trick.
This flickering occurred for me when I there was scaling involved in the mesh animation, and the physics bodies were not the correct size.

Turning up the higher bounds will work… however: the bounds determine when an object should stop being rendered while off screen (aka culling). If that bounds is too big, it will always be visible, but may cause a heavier strain on your graphics performance, especially if you have many objects with high bounds.

For something like my scene thats real world scale and default value is one, what value should I try? I go as high as 10 and I don’t see a change in the flicker.

1 Like

I got some fair results by disabling dynamic shadows on all the machines, but i lose all shadows all together. hope this works out during build lighting since i’m using static lights

Legit fixed this by completely reimporting the mesh, delete the mesh you already have and just hit the import button and import it again, DO NOT RIGHT CLICK AND CLICK REIMPORT cause that issue was caused by doing just that

Legit fixed this by manually deleting the mesh and reimporting it by hitting that import button. DO NOT RIGHT CLICK AND HIT REIMPORT AS THE ISSUE IS CAUSED BY JUST THAT. Hope this helps anybody…

Muito Obrigado Salvo demais!!!

Adjusting the bounds value worked. Thanks!! @anonymous_user_6f0e22f9

Useful 7 years later. Thanks.

bit late, but thank you!!

Mine was solved using: Attach to parent bound (Multiple skeletal meshes)

But definitely a bounds issue.
Thank you.

Thank you for this answer, 8 years later, it’s still a lifesaver.