Download

Flickering Light Shafts

Hello

I’ve enabled “Light Shaft Occlusion” and “Light Shaft Bloom” in a directional light, and I can’t seem to get rid of the flickering. Other posts are mentioning the “camera frustum” as a possible culprit, but I can’t seem to find any direct solutions to this.

I have a slow-moving camera and light shining into static geometry, so the flicker is very noticeable.

Any tips?

Here’s a gif of the problem: Flickering in UE4 - Album on Imgur

That looks like it’s probably due to temporal anti-aliasing, which is something that is done over multiple frames which is why it’s flickering like that when the camera isn’t moving.

@darthviper107 You’re spot on! Disabling AA in the viewport Show-menu eliminates the problem. However, I’d like to have AA, of course. I set this in the project settings under rendering/default settings, but I can only switch types. I’d like to crank up the samples as well. I can’t seem to find it under post-processing volume or camera settings. Any hints as to where I might set 2x, 4x etc?

Using FXAA in the project settings, there are some flickering fireflies in materials with specular or reflective highlights.

EDIT: I’m using Ray Tracing, and it seems to have something to do with the Ray Tracing Reflections, found under PostProcessVolume/Ray Tracing Reflections. Adding samples doesn’t seem to help. Turning off RT Reflections makes the fireflies go away, obviously.

when adjusting samples for ray tracing reflections the denoiser turns off if you increase the samples higher than 1