Download

Flickering foliage

Hi.

I have a strange foliage bug on my landscape. Groups of grass instances are changing brightness, when I move camera. This video shows bug:

Grass near the road become darker or brighter.

Engine scalability settings are all Epic. Other settings and material:
18661-grass.png
18662-mat.png

What happens when you disable the “eye adaption”? -> in the post process volume under auto exposure :slight_smile: + place some meshes by hand and then check if your problem still appears

I disabled all posteffects, and it doesn’t solve problem. But I solved problem in another way.:slight_smile:
When I uncheck Cast Dynamic Shadow on the grass instance in foliage window, this visual bug disappears. But the foliage don’t cast shadows! It’s not a big problem with grass, but when trees don’t cast shadows, it looks ugly.
I also got this message:
grass2.png

Large actor? It’s only 300 instances. I’m going to cover all level with the grass and trees and I want them to cast shadows (maybe not grass but trees any way). How can I fix it?

Detailed bug description:

  1. Foliage looks good when I uncheck Cast Dynamic Shadows - but it’s not a solution.
  2. Foliage looks good when I set DistanceField Shadow Distance less then 7k for this level.

You can see it in the video from Editor.

https://www.youtube.com/watch?v=PxIm-uSUqeE

How to fix it?

On your lights, such as directional light, check static instead of stationary/movable, which make it dynamic. If you need the sun to change directions then that might be an issue. A quick fix for the time being I suppose. Then I look at the time stamp of this post, and it’s been 4 years hahaa. I hope you ended up finding your solution.

Try disconnecting the emissive color. The behavior though looks like a LOD kicking in so I would look at the mesh to see how many levels it has. It’s typical to LOD a material to decrease the level of shader complexity so the behavior looks like the emissive kicking in and out.