Flicker between meshes

Hello, may I know the cause of these flickers? I am sure that there are no overlapping meshes and it only occurs in PIE, not in editor viewport. What should I do to fix this? Thank you.

What are these? Is it the editor cube, or your own meshes? If the second, are some parts of the mesh open?

What sort of lighting do you have? ( static or dynamic )

editor cube. I tried making it emissive in an unlit map it looks perfectly snapped. I suspect the lighting.

Have you turned on anti aliasing?

Ok, well if it doesn’t matter ( which it wont unless your a static lighting nut ), just switch directional to moveable and skylight to stationary. What happens then?

I tried and here’s what’s happening

Here’s my material.

Ok, starting to run out of stuff here. A few more ideas:

  1. Have you tweak ANYTHING in project settings? Does this happen on a new default project?

  2. Have you tried visualizing out of bounds pixels?:

  1. Make sure you have the latest drivers for your card.

I’m using default lighting not sure how to check if static or dynamic but it says mobility: stationary and no anti-aliasing.

Ok, now I’m wondering about the material. Is it just 50% grey or…?

Is it for a mobile game? If so, there might be settings in the material that are not compatible with the mobile renderer. It’d require searching on the site and/or elsewhere to see how to set up mobile game materials correctly.

For the Out Of Bounds Pixels check, here’s a link to how to use it: