FleX Nice Water


I am Involved in a project that needs to use FleX to simulate water and other fluids. So I started working on it and I got the following situation and don’t know how to fix it. I also want to make it look more watery kind of like in the demo, if somebody has worked with FleX before and can provide feedback on it it would be nice.

The demo in question: PHYSX FLEX DEMO - Incredible Physics Simulation - YouTube

The screenshot of the disaster:

Any help will be greatly appreciated.

Firstly you need to make sure the water particles dont render in the main pass (There is a tick box on the particle emitter) because I can see the FLEX particle balls still, this will make it only render the fluid. Then try to use the Flex thickness material variable to control the color of the water based on the thickness.

Oh that’s it, I did see it somewhere but wasn’t sure what it was for, thanks!

i dont see the tick option in the particle emitter, can you put a pic?

When you place an instance of the particle system into the scene, look at the details panel. Under “Rendering” it will be “Render in Main Pass” just untick, if you need further instructions, look at the FLEX branch there is documentation on how to set up FLEX particles and such in UE4 along with screenshots.

hello,i’m using ue4.16 with flex.I cannot find “the Flex thickness material variable to control the color of the water”,can you tell me how to change the water color?