Download

Flatten Mapping

Hey guys,

I have been trying to solve my UV(Lightmap) issues. I have some architectural geometry , which is impossible to Unwrap UV’s manually. So, i use automatic unwrapping system on 3ds Max ( Flatten Mapping ) . However with the most of my complex objects , it doesn’t work. When i import it to Unreal and build it , it keeps saying there are some overlapping UV’s and my material looks so awful on the object.

It doesn’t make any sense because flattening mapping should unwrap every single face and lay them seperately. So what’s the problem? I don’t need a manual unwrapping because most of my objects will be assigned just colors. No textures.

I want to know if anyone else is having the same issues.

Thanks.

Maybe problem is in resolution of lightmap. I think when you unwarp complex high poly objects, you get lots of tiny uv islands. When free space beetwen them is less than 2 (or 3) pixels, unreal complains they are overlapping because edges of 2 different pieces are on same pixel.

Also flattern in 3d max is terrible tool for creating lightmap uvs. You kind of cannot cut corners here, either you do that work manually and get good lighting uvs, or you get crappy (with resulting artifacts) doing automated job.

There are good unwarping applications out there, and max has improved recently in this area.

Hey Querorz,

If you’re getting the Overlapping UV error after flatten mapping go into the UV editor and go to the menu bar > Select > Select Overlapping faces.

If there are any overlapping faces in 3Ds Max at that point you’ll see them highlighted. If you don’t see any issues go ahead and export to UE4.

If you’re still getting the error there open the mesh editor > select the UV icon in the toolbar > From the dropdown select the UV Channel 1. If you see any red areas this will be the parts that are overlapping. Also make sure that the correct lightmapping coordinate index has been selected. You can find this in the details panel on the right in the mesh editor > Static Mesh Settings > Lightmap Coordinate Index. This should be set to 1 if you’ve set up a second UV channel.

Give that a shot and let me know.

Nawrot, thank you. Here is a part of UV’s of a huge building. Thousands of tiny islands as you said. On UV render , they are not overlapping. But i guess what you are saying is even though they look fine in render(which is 5000x5000 ) , there are probably less then 2-3 pixels between them in actual UV base. Because UV base(or whatever you call it) is only 2048-2048 pixels large and thousands of islands will have very little gaps in between? Is that right?

But, even if i unwrapped this building manually, there would be very few pixels between UV’s anyways. Because unwrapping them myself, doesn’t change the number of polygons and they will still cover a huge area.

The building i am working on is inunwrappable :slight_smile: . It will take months to do it manually. So, i need an automated system for unwrapping. Does such a thing even exist?

testtttttttttttttttt

Just a short note -> due to a spam problem in the past, moderators have to approve your first posts. That’s why it could take a while till your posts gets displayed :wink:

Tim, thanks for teaching me that “select overlapping faces” thing. Very important point.

So , i did what you said and fixed all the overlapping faces and imported my model to UE4. When i built it , no errors at all. But the building looks like this ( I put another object to see the difference in the back ) .

( Sorry for my “testttt” message :slight_smile: )

Tim , i did other things you told as well. Some of the objects don’t cause errors but materials on objects still look like s.it. :frowning:

I can buy any software to fix this issue, easy way. I am open to suggestions.

You’re going about it the completely wrong way. There’s a lot of things that need to be done. First, you need to break up the mesh into multiple objects, you shouldn’t have it all as a single mesh. Especially if something is used more than once you only need one of them. Also, for lightmapping you would need to make sure that the meshes are split enough so that you have enough lightmap detail, so if you can’t get enough detail with a high resolution lightmap then you need to split it up further. It also looks like your scale is too small. 1 unit in UE4 equals 1cm.

Yup what Darth wrote, above.

I just want to add that for such buildings, split it all into sections/modules.
Then make blueprint that creates buildings out of those meshes in construction script.
This will save you time later.

Guys, i see what you saying. I started dividing splitting my building now. Is there a way to increase UV base size guys?(so UVs will be more detailed)

My second question is what is “Overridden Lighting” ? When we check this option on UR4 , some of the objects suddenly looks all right.

When you check that option it’s reverting to dynamic lighting until you build lighting again.

The override allows you to set the lightmap resolution you would like if you need it to be an instance specific thing. Otherwise you can set it via the static mesh editor > Lightmap resolution. The default resolution is set to 32 which is quite low if you have a large object.

Breaking the mesh into pieces as suggested and using a LM resolution of 512, 1024 could possibly help. I tend not to go higher than these unless it’s absolutely needed. Which is very rarely and typically only when I’m testing something.

Having a good UV layout will help more than anything else at getting the most out of your Lightmap UV and having your asset broken up so that the pieces can occupy more of that UV space is key to getting decent resolutions with your mesh.

Thanks Tim. I get what you saying. Will using Blender make unwrapping any easier?

I have a new problem. When i import a house with all different component(railings, windows and walls) . UV’s of all the objects will be stored in only 1 UV base. So all they are overlapping. You can see railing’s UV’s over Windows’ and walls’ UV’s . That is probably one of the issues troubling me.

Personally, I’ve not used Blender so I can’t attest to their Unwrapping ability and ease of use. I use 3Ds Max with all my modeling and unwrapping. I’ve tried some of the add-ons to make Unwrapping easier like Unwrella and the standalone program for Headus UVLayout. They all have their goods and bads I’m sure, I just didn’t need them beyond the trial to continue my work.

For the overlapping UVs. If you’re using multi-sub object textures so that you can have all these pieces occupy UV 1 and use different materials that should be fine. I use this method a lot. As long as each material is assigned to it’s own object the material ids will be OK and now show metal railing on the windows where they overlap. In this type of case the UVs overlapping is not a major concern.

In my opinion it’s nearly the same as in other 3d programs (3ds max, maya, C4D) -> you can either use the existing features or download a plugin :slight_smile:

Tim, it’s so weird. When i import only 1 object, UV’s are fine and when i build it , it look OK. But when i import a couple objects at the same time what i told before happens. And non of them are assigned multi-sub object.

Fighter, thanks :slight_smile: . I thought so.

When you’re importing are these all individual objects in a single FBX that have the “combine meshes” option disabled on the import window or are these separate FBXs that all have mult-sub-object materials?

Also, just to confirm, you’re on Version 4.6.1?

Timmm, dang it! I didn’t know such an option existed. Wow! Thanks. Let me keep working on the project for a while. I am sure i will come across with more and more problems soon. Thanks :slight_smile: .

haha no problem. :slight_smile:

I check the forums often, so if you have any issues feel free to post. If I’ve not checked in a couple of days feel free to shoot me a private message if none of our awesome community members have offered any help as well.

EDIT:

I’ve just added a new Wiki page to my forum posts here: https://forums.unrealengine.com/showthread.php?56777-Photons-Be-Free-Mini-tutorials-and-other-curiosities&p=220501&viewfull=1#post220501

This is listing all the troubleshooting and lighting tips that Eric and I are working through to get listed.

The page is already active on the Wiki with some issues. One that is on our list to get to is unwrapping large objects with a comparison of Flatmapping vs breaking into smaller pieces. This is really a common issue that comes up and it could be helpful for others like yourself that run into theses issues and don’t know exactly what to do. Feel free to add to the post if you’d like to see anything added that’s not listed or have any suggestions for anything else. :slight_smile:

Tim, thanks so much. Great to know having someone like you ready to help any time. I loved your little tutorials. Thank you.

Guys, isn’t there a plugin on unreal engine that works like “UVW Map” on 3ds Max? Do i have to do unwrapping for everyyyyy single object on Max? Even for the objects that doesn’t have any texture on it? For the ones that only have a white color material on it? There gotta be something to handle this operation easier way.