Download

Flat Shadows

I’ve been reading the forums and I cant find a solution to these flat shadows. I’ll try and keep this short and to the point. I textured and applied basic texture maps and UVW’s(to channel 1). Exported to FBX, opened up a new level in UE4 V. 4.4.3 imported the mesh and set the UVWs to channel 1. Built the lighting and all the shadows are flat. I didn’t have this issue in a previous version however I’ve been out of UE for several months. I’ve attached photos of everything below. I appreciate any help or direction as to what I’m doing wrong here, thanks!

Your building needs to be split up into a bunch of separate meshes, the way that is it can only have a single lightmap for the entire thing, even at the highest resolution lightmap you won’t get enough detail.

Ahhhhhhhhhh ookaaaayyy, that explains why. So I guess the floors, walls and windows with all be separate. In 3ds Max should I attached all the walls into one mesh and then apply the UVW; so on and so on with the floors and what not?

yeah, something like that, just remember that the more detail you want in a lightmap the higher resolution you need it to be, so if you’ve got lots of large surfaces then you might have to split them into more separate meshes so that it uses more lightmaps. For instance, I did a model of our office and I had several floor meshes. You can export the separate meshes out of 3ds Max into a single FBX file, just remember when you import to UE4 to uncheck the Combine Meshes option, otherwise it will make it into a single static mesh like you already have.

I’ll give it a shot, thanks for leading me into the right direction!