Download

First person template VR collider issues

Afternoon all

So, i am creating a project, Arch Vis type stuff. We have an .FBX file, which has come from Autodesk Revit. We have exported the model from Revit, opened up in 3DS Max and re-exported to .FBX after removing some stuff. Once we have the .FBX file in the project, we go into it and set the collisions to complex, and they look accurate.
Everything works fine when we preview/play the game in normal first person (no VR) but when we test in VR using Oculus, the camera drops to about 500mm from the ground and it is as if the camera has been offset to one side. We can walk flush up against a wall on the right side of the building, but on the left side of the building it is as if the colliders are offset 1000mm, meaning we cannot move all the way to the wall. It seems like a constant offset on all geometry (NOTE: The same issue happens on native Unreal geometry, so does not seem to be anything to do with the .FBX file)
To sort the height issue, we plug in a “base rotation” node into the “EventBeginPlay” node in the first person blueprint and give it an offset. But we cannot fix the collision issue.

any help is appreciated

EDIT - Using Unreal Engine 4.16 (Same issue in previous version)

Hi,
Sounds like something is off with your collision capsule / VR camera position or the way you initiate your VR mode:

  • Is your VR Camera inside a Scene Component (VROrigin) inside a collision capsule (root)? See here: https://docs.unrealengine.com/latest/INT/Platforms/VR/VRCameraRefactor/
  • Did you set the Tracking Origin to Floor Level on Event Begin Play? By default Oculus is set to Eye Level, which may not be what you expect for your walk-through application
  • Is the Player Start component set properly in the scene (usually with its mid point at floor level)?
  • Did you call Reset Orientation and Position after setting the Tracking Origin to make sure you start with proper centering? As an alternative, you can link the Reset Orientation and Position to a key/button on the controller
  • Does your VR Pawn have a proper Movement Component? Or how are you moving around?

Cheers,
Marco.

Hi Marco,

Thanks for getting back to me. I am using the first person shooter template and character so the movement is all pre set by that character. When I preview the level without VR everything works fine, however when I use the preview in VR this is where I get the issues.

Do I need to make a new VR Character or should the default FPS character work?
Note - I can get the VRLocomotion character from the VR template (Teleport one) to work properly in my file, but we are looking to be able to walk around to inspect elements etc.

Cheers,

Hi,
The FPS character is also VR Ready, so it should work properly. What I suspect is that the VR Camera is offset respect to the VR Origin so you virtual head is actually on the side of the collision capsule (your virtual body). This can happen especially if you start the VR Mode with your Oculus on the table on a side and then put it on after that.
I would try this:

  • Add an Key Event to your level or character Blueprint (on the Space bar key for example) and from it call Reset Orientation and Position.
  • Start the VR mode in the Editor.
  • Wear the HMD.
  • Reach out and press the Space bar key. This should reset your orientation and position in VR so that the Camera is aligned with the rest of your virtual body.
    See whether this fixes it.
    Cheers,
    Marco.