First person hands disappear when looking in certain directions

Whenever I either look up and down or when I am looking horizontal and have a rotation of 90°, my first person hands disappear. I think that it is because the hand’s 0,0,0 point is behind the camera. Is there a way that I can make a mesh always be rendered no matter what?

Video example

In the video, I have shown an example of what is happening and I have also put an exact copy of the hands in front of the player’s view to almost prove that my problem is because the hands are behind the camera.

Have you modified something, scaled or moved the mesh for example?

You could check if the bounding boxes of the player hands are right, maybe there is an issue with that.

I didn’t put it in the question, but I have the first person hands -30cm behind the camera which is what I meant by “the hand’s 0,0,0 point is behind the camera”

as StefM said, move or scale your hands bounding box so that it is not culled from the perspective view.

Because I didn’t want to move my hand’s position, I had to change the “Bounds Scale” to a higher value which allowed it to work propperly. Thank you to SteffM and LeFxGuy for their help.

http://puu.sh/uSfSw/598ddd5a06.png

btw if your hands are attached to something else, you could use the “Use Attach Parent” property. This way, the component will use the bounds of the parent. This can, I think be quite nested. I haven’t tested anything but it would be possible to use a “box collision” object or something as the parent or maybe even your character or something would be enough to make the arms not disappear. Although I just wanted to give that hint and i think there is nothing wrong with using the bounds scale for this one object :slight_smile:

I tried what you said and it worked although, it seemed like a less simple of an answer. Since the first person hands don’t even use collisions, and only the owning player can see them, I think it’s the best solution (I assume that I know what increasing the bound scale will do other than fix my problem). Thanks for giving me the option though.