Find Advanced Session returns 0 sessions

I’ve been trying to get the find advanced sessions to work and i’m testing with Steam, but it keeps finding 0 sessions (I printed the length of the results).

I’m trying to use Find Advanced Sessions to check the session if it’s MapID matches the player’s selected MapID. (So only sessions with the same MapID can be connected to), However, it’s not showing anything, even when I tested every single setting individually (on and off / changed min slots available to 0, 1, 2, 100). I did promote my Max Results to a variable that has a default value of 20, and tried up to 400, but still no results.

It works when I hook it up to just the regular Find Sessions though. I can even Get Extra Settings > Get Session Property Int to get the MapID that was set from my Create Advanced Session to compare it with and everything works perfectly with it.

So would it be appropriate to leave it using the regular Find Sessions? Or would it eventually causes issues when carrying over to other Online Subsystems such as Google Playstore? Should I get Find Advanced Sessions to work instead? Thanks for any advice! (I would like to know any possible solutions as well to get Find Advanced Sessions to work too if possible :slight_smile: )

The setup is almost identical to Wes Bunn’s set up from his tutorial series (Blueprint Multiplayer: Project Overview | 01 | v4.11 Tutorial Series | Unreal Engine - YouTube)

1 Like

Minimum slots available being 100 means it wont show anything unless there are 100 slots available.

1 Like

set the var "public connections"larger than 0 in fun “create session” will be ok.