FBX Smoothing Issue

I have tried several ways, but I guess I haven’t found the correct way yet, that or the FBX smoothing import doesn’t work correctly. Would be great to get imports in Unreal that support .ma and .max!

The model is smoothed correctly in Maya, but looks like **** in UE4.8.3

First two images are from Maya 2014 the last two show the smoothing errors in UE4.

Hi CryBaby -

On the FBX initial import into the engine or in the Build Settings of the Mesh, Select the Import Normals and Tangents option and import (Build Settings). This setting will default to only settings saved with the FBX from Maya.

If this does not work, please make sure that you are not viewing your model in smoothed mode in Maya, you can test this by selected your model in Maya and pressing the number 1 (above Q on your keyboard, not the number pad). IF the smoothing goes away, you will need to select your edges and set the Normals Hard or Smooth and once complete reexport the model again.

Thank You

Eric Ketchum

Okay, Eric Ketchum was right, I forgot to smooth my model in Maya, sorry. However when I import into UE4 everything is great except the base isn’t imported correctly.

Hi CryBaby -

Looks like you normals are inverted, look at the Face Normals and see if you don’t have a few faces flipped.

Eric Ketchum

In Maya, you would go under Display >> Polygons >> Face Normals. In UE4, you will open the mesh in the Static Mesh Editor and select Normals from the Icons in the Toolbar. This setting will be vertex normals in UE4 but you should be able to see if they are pointing the wrong way.

Normals will always point to the direction that they will render (facing direction).


Got it, thanks!