FBX skeletal mesh imports as multiple objects

Hi, I’m trying to import an .fbx file as a skeleton mesh and I need it to be one asset. In 3ds Max it’s several objects that I select and export as a single .fbx file. But UE4 keeps importing them as several separate skeletal meshes. I know there is an option “combine mesh” for static mesh import, but I import a character for animation and I need it to be a skeletal mesh. Is there any way to import it as a single asset? Thanks.

Because your bone groups are seperate unreal will always read it that way. It’s the nature of animations and rigs. If you want it all as one skeletal you will have to combine them in 3ds max

So I just combined it all in one mesh with multiple elements. Even though I still can’t import anything as I’m using CAT rig and it gives me “can’t import asset, multiple roots” error, I think it will be a single mesh now though.

Maybe you can try importing the mesh into Blender and parent/childing the mesh making it read as a whole. I tried that multiple times and it has worked.

By default the unreal engine do import as a single object, even if you have multiple object selected when export. But I just had this weird problem today that all the skeleton mesh I import to unreal engine turned into multiple objects and multiple skeletons, I tried both 4.15 and 4.14 with no luck.

Thanks! This worked well for me too

Thats not true. You dont need to combine the parts in the 3d app to have em combined in UE. I am having this exact same problem but i know it should work because the first time i imported my skeletal mesh into UE, it automatically combined all the parts. I needed to delete the imported mesh because i made changes in blender, and when i go to make the same import process in UE, this time i cant get the whole mesh in one piece.

Any ideas?

That´s worked for me as well!


For this multiple import issues, there is a settings in Maya only. Kindly go to the Outliner Window and Select what are object need to make one object in outliner then press crlt + g it make the groups then export and import to UE4 then it import as single object.,

I’ve noticed that this also can happen if the Skin binding process was not properly finished. (Rigid + Smooth Bind)

I know this topic is quit old but I think you can still help me.
I have the same problem but reversed.
I need to import my FBX as multiple skeletal meshes but unreal still merge them into one mesh.
This is a car mesh and I’ve done multiple mesh for the texturing to keep a certain quality.
So if anyone have any idea of what I can do, go ahead, I’m listening!

Well how about trying to do the opposite of what moutof1deas answered. Make sure all the bones that you want as separate meshes are separate from the root bone, ie: not childed to the root bone. That should work