FBX Crash 4.14.2 with multiple material IDs

After upgrading to 4.14.2 from 4.14.1 and while importing FBX files, I get crashes when i try to save them after import. Also crashes instantly when re-importing files, even if the File was unmodified since importing them originally.
How can I roll back to 4.14.1? Because 4.14.2 does not work for me.
link text

i am getting the same error, i have sent the crash log also. can not import any fbx files after updating from 4.14.1 to 4.14.2

I do believe there is no rolling back of your project, also Epic does not offer older hotpatches for download.

Certain FBX import created crashes a few version back but they fixed it, I believe it was 4.9 that crashed for me when importing.

What I did then was to set up an older version that still did the FBX import correctly (for me it was 4.8), create an empty project that I used only for importing FBX and then import and save FBX files there and afterwards migrate the resulting assets to my main project which used the newer engine version

I tried that with importing to an empty project, Didn’t work! OMG what am I going to do ?!
Anyways I rolled back to 4.14.1 by downloading the source on Githib and recompiled that from scratch and opened my project with that. I hope this issue gets fixed soon !

I have uploaded my FBX in the first post, maybe someone can see if it works in their 4.14.2?

If I test with the fbx you provided it crashes for me too. If I create a .fbx in blender and import it in ue4, it works. Your .fbx also opens ok in blender.
What 3d editor do you use ? I know they have slightly different fbx exporters. Maybe this could help epic narrow dawn the cause.

I just upgraded to 4.24.2 and I also can not import an FBX file, I’m desperate to get someone to help me please.

I got the same problem :frowning:

I tried your file on 14.1 and it worked and on 14.2 and it crashed indeed. I could import it on 14.2 as “fbx scene” not sure what that means, but when importing it as the default static mesh, it crashes

How do I revert from editor 4.14.2 to 4.14.1, actually importing FBX does not work …

I Use 3DS Max 2015, its kind of strange , because I have lots of models inside that max file and I export by selecting a model than exporting selection. If exporting all the models in 1 FBX file than I don’t get a crash. (sometimes)
(as a recap the models have been able to import in every version of Unreal 4 that ive had up till now. i haven’t changed a thing, some of them go as far back as when i used UDK for my project. I even tried to export from Max 2017 BTW from completely new scenes.

Seems you have to download the source code and make a new build. there are instructions where you download the source code that run you threw compiling a new build from scratch.

Hello, importing as skeletal mesh and then in the editor convert to static mesh, was the maneuver that I managed to do to advance my project before the correction of this bug.

Same problem here :frowning:
In my case I can import some fbx files, but most of them just crash the editor. I’m working with Blender and the models have been exported exactly with the same settings I was using just yesterday and worked perfectly well.

Hi all. We understand that this is a significant issue and are currently looking into our options for a solution. We will keep you informed.

Hi everyone,

Thanks for the test asset Tuxmask! I was able to get the crash and I’ve submitted a ticket for this and we are investigating.

Thank you!


Try import with a standard materials from 3ds max

The description of the bug report says that the crash only happens on meshes with multiple material IDs but I am getting crashes on my meshes with single materials as well. My FBX files are binary and exported from Blender. In my normal Blender workflow, I do not assign a material to my meshes in Blender if they are only going to have a single material in UE4. This has always worked in the past, however, now I also get this crash when importing any FBX that wasn’t assigned a material in Blender before hand.


Can you provide a test asset? There are two things with this that were brought up when we were investigating. One engineer suggested it was because when the mesh imported it was really small. This was fixed though by putting a check in for these tiny meshes, so that could be likely an issue. and the other which I reported above was to do with material IDs. I was able to see that anything more than 1 material ID would cause the crash.

Thank you!

Here is an asset which causes a crash and one that doesn’t. They each only have one material and I don’t think the problem is that they are too small. link text


I’m not sure this is the same issue since I’m not getting the crash at all when I import into 4.14.2. Both import correctly that I can see and they certainly aren’t tiny meshes.

Can you create a separate Bug Report and post back here with the link. I’ll assign myself so I can take a look. Also include your full log, call stack from the crash and attach this zip file with the two assets.

Thank you for getting back quickly!