Download

FBX Collision errors

I’m running some tests to see if I can get away with using Sketchup models for full buildings with interiors. I’m using Sketchup make, so I have to export as .dae (collada) but I convert it to FBX using Autodesk’s conversion plugin, import that FBX into Maya so that I can export it as an FBX again, but with smoothing groups, and then I load it into UE4 from there. So in Maya (just on a simple test mesh) I’ve tried duplicating the mesh and naming it, “UBX_MESHNAME” without the quotes and with the proper mesh name, but no collisions are generated, even though that 2nd render mesh isn’t rendered. IT doesn’t work for UCX either, but oddly enough a collision primitive was generated when I tried USP. Am I doing anything wrong? The reason I’m going through Sketchup is because I can generate fully explorable buildings with complete seamless interior layouts much faster in Sketchup than I can in Maya (it’s actually a huge pain in Maya.)

Here are some screenshots of my mesh in UE4, though no collisions are made.

Can an admin please delete this thread? My problem has resolved itself, it was an issue of that actual mesh, not any import/export woes.