Fatal error rc1015 | on fresh install

Google isn’t really helping me here.

How I got this error

1.) Create a new class
2.) Edit the class
3.) Attempt to view Solution Explorer
4.) [Error]


What I’ve tried

  • Rebooting
  • Reinstalling UE / Visual Studio 2013
  • commenting the #include out - Just more errors
  • manual search for this “Runtime/Launch/Resources/Version.h” - * No results *
  • automatic search for “Version.h” - * No results *

I was about to create the file… But I have no idea what it needs.

So, this file… I guess doesn’t exist. Does anyone know why this is happening? Why is Visual Studio automatically adding #includes to code that isn’t auto-generated? I have been reading through the UE docs, and it’s not really telling me anything about this.

Does anyone have a fix for this?

Hi ,

Sorry for the delay in responding to your post. Is this still an issue for you? If so, would you be able to provide some additional information?

  • What version of the Engine are you using?
  • Are you using the binary Engine installed through the Launcher, or did you build the Engine from source code?
  • What steps are you following when you add a class?
  • What edit(s) did you make to the class?
  • When you say “Attempt to view Solution Explorer,” what do you mean (my Solution Explorer window is always open and visible)?
  • What happens if you try to build the project? Does it yield the same error message?

The Version.h file that the error messages references is part of the Engine’s source code. However, none of the classes that I have added to a project have ever explicitly included this file.

Hi ,

We have not heard back from you for a few days. Is this still an issue for you? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment and re-open the post at any time if you need any additional help.

Oh, I’m sorry. I had forgotten about this and I don’t check my email too often.

I didn’t fix it, but it turns out I don’t really need to. I was clicking on explorer, when I don’t even use that feature. Also, it’s less of a UE issue and more of a IDE issue. :slight_smile: So, I just decided to use gpp instead.

cheers :slight_smile: