Download

Far distance tree shadwos disappear after build light

After change parameters light “max draw distance” shadows render max distance even is value 0.001 but after build disappear wtf? What setting use to max distance shadow dont care about performance

If max distance is in Unreal units, then 0.001 is 1/1000th of 1 centimeter distance. Try 100,000, or 1 million.

Not working even i set 100000000000 , shadows renders far away only before light bulding, shadows start showing if i rechange this value but shadows are preview

what are the directional light settings for shadows? is CSM enabled, settings?

CSM is enabled, light source stacionary (movable also not working), rest settings deafult

Try checking the mipmaps of the trees and material of the trees. What trees and materials are they? Megascans, from a different program such as 3DSMax or a foliage application, or…?

InstancedFoliageActor_0 Instanced meshes don’t yet support unique static lighting for each LOD. Lighting on LOD 1+ may be incorrect unless lightmap UVs are the same for all LODs.
I have this warning maybe that why?

Yeah, it is probably why. The more I’ve learned about LODs, and reading different posts with similar issues of things disappearing or getting weird lighting, the more I suspect LODs are probably the problem if it’s not a few other things.

So, LOD 0 is the maximum, best quality LOD…unless you specifically change it to be not that…or the imported mesh/material has it set to not be. With landscapes, there’s a built-in LOD system that’s said to smoothly transition from one LOD to another. LOD means level of detail, so higher LODs (above 0) are successively lower quality / less detail. My understanding of the docs on it was that, to get accurate static lightmapping for each LOD, it requires generating the lightmaps for each LOD that’s enabled. It seems simple, but it’s really not. Try opening every mesh in the foliage that’s having problems rendering shadows and checking to see if LOD 0 is the only LOD enabled. If it’s not, then disable / remove the higher LODs. Even if the LOD is maximum at a far distance of viewing, it’s only a small percentage of the screen, so it shouldn’t look terrible or affect performance drastically. Unless there’s something I’m missing about that, but it’s worth a try I think.

I have 4 LODs, I dont disable 3 becouse performace drop, last foliage is bilboard and also got shadow but not far away as I want what I must do to increase shadow render distance?

Its more likely that your billboard material is bad / doesn’t cast a shadow than anything else.

but why its ok before light bulding, its show up when I change some arameters in light but after that my screen show information “light need rebuild”, I made video later

Ok I I experimented and problem is my mesh, I drop mesh to Meadow Eviroment asset Map and there all trees got far distance shadow but not mine, so I set every setting my mesh as like this trees but not fix my problem what I do wrong? Also I have this warings

spruce Object has wrapping UVs.
spruce Object has overlapping UVs.
spruce Lightmap UV are overlapping by 98.3%. Please adjust content - Enable Error Coloring to visualize.

Ok somehow fix this mesh reimport from blender fbx. But now another problem (Good Lord give me patience to this engine) this shadow look very low resolution were I must change some setting becouse if I change in mesh light resolution nothing happend