Far Away Raytraced Reflections Lose Direct Lighting

I’m having a problem with raytraced reflections in my UE 4.27 scenes. The lighting in the reflections seems to cut out at some distance but I can’t figure out which console variable controls the direct lighting distance for raytraced reflections. Here is what I usually see:


The lighting disappears in the reflections of far away objects.

I can soften the effect a little by turning on r.RayTracing.Reflections.Hybrid 1 which seems to blend screen space reflections with the ray traced reflections.

I also found a console variable that turns off direct lighting in reflections altogether, r.RayTracing.Reflections.DirectLighting 0, but that’s not what I want either.

Any suggestions on how I can get UE to use direct lighting in far off reflections?

Thanks!
-Donald

Anybody? This seems like it should be something really basic or something is really broken about the way UE does raytracing. Placing objects on a reflective surface seems like it should be a no brainer. Has anyone else had this issue?
Thanks in advance!
-Donald Newlands

??? (help!?)

This may involve a different setting than a ray tracing one for reflections, such as the skylight or post process volume. I suggest doing a bit of research in the docs on the reflection environment and also try looking for a ray tracing cvar involving trace distance or screen space trace distance for reflections. There’s a problem sometimes where screen space reflections, if turned on or occasionally when turned off but not correctly turned off, override ray tracing. Is the project set to DirectX 12 RHI? It’s another thing that could be a source somehow of the more distant meshes not having their reflections lit and looking right.

Did you manage to find any solution? I am facing the same issue, the ray trace reflection seems to ignore direct light at a distance.

I have found a solution that works for me, hope it helps anyone struggling with this problem, use the following console command.
r.RayTracing.LightCulling.Cells (use a value that is suitable for your scene, i used 18)

2 Likes

It worked! Thank you!
What drives me mad though is these kind of settings should be available somewhere in a more easier way to find. The documentation is very lacking on topics like this.

1 Like