Download

Fails to install Android SDK, NDK, etc properly

I am trying to runa test cardboard vr app on android and started by following this guideuntil I got to the part where I had to add the SDK, NDK paths, at which point I realized I had to setup all of those. So, I began following this guide to install Studio and all that, but it fails at the part where you run androidsetup.bat. It gets to sdkmanager.bat, then says something about not finding something and downloading, then a bar starts across, gets to about 6%, and then the bar disappears and says it failed to find package 11db;3.1, and tells me to check the android studio install, as seen in the attached picture here.

I have done some decent troubleshooting. At first I figured it was because I also had some old install of AndroidStudio from some ROM work that I uninstalled but might have had some lingering files, so I tried to fully remove Android Studio, the SDK, and all other related files, as well as updating Java before reinstalling studio and running it again. It had the same behavior as above. I redid the entire process several times with the same result. To ensure it wasn’t something to do with my specific machine, I installed UE 4.25.0 on a different machine that had no other versions of UE, and had never had any Android related files whatsoever. It also failed at this step in the exact same way, so this issue doesn’t seem to be device specific.

Is there something glaring I am missing? And if not, can anyone else confirm this behavior?

Thanks in advance for any help you can provide.

I am also getting the same issue on the Mac as well. I also did a clean Mac OS and UE4.25 install and still get the same error.

I am also having the same issue, I think it may be something to do with my account not having admin permissions. I’ll report back if i find a solution.

having the same problem

I had the same error. I’ve got able to bypass the problem by editing the SetupAndroid.bat, line 75, and removing lld;3.1 from the install list:

call “%SDKMANAGER%” “platform-tools” “platforms;android-28” “build-tools;28.0.3” “cmake;3.10.2.4988404” “ndk;21.1.6352462”

Thank you! worked for me

Same problem and same solution. Thanks!
In addition: I had to create an empty “repositories.cfg” file in my /.android/ user configuration to bypass another check.
Some improvements are needed to the Android dependencies installation.

Hello Guys, thanks its worked for me.

Special thanks @xadamxful

Best regards

Same and Same.
Also needed empty “repositories.cfg” file.

Proper thanks! @DarknessFX, @F3NR1S

It works, but we still need** LLDB** for debugging.

Thank you! <3

It works to me. Thanks.

i did this but after i got this error :

Accept? (y/N): y
=======================================] 100% Unzipping… android-ndk-r21b/sha
The system cannot find the path specified.
Success!
ERROR: Invalid syntax. Default option is not allowed more than ‘2’ time(s).
Type “SETX /?” for usage.
ERROR: Invalid syntax. Default option is not allowed more than ‘2’ time(s).
Type “SETX /?” for usage.
Update failed. Did you accept the license agreement?
Press any key to continue . . .

Ia have the same problem

I’m getting the same error, and I haven’t been able to find a solution yet :s

I just made a video on how to do this in unreal 4.25 https://youtu.be/7c2L3OjabV4

I’m still having this issue after running sdkmanager.bat --licenses

EDIT: Updating to 4.25.1 fixed this for me

However, I will say that since the 4.25.1 update, nothing seems to be working, I get a completely different error now that isnt even echoed from that batch file,

thank you brother it works for me but hope no other issues will come.

I watch your video. Its help solve some problems. Thank you! But im have a new one. After im accept license agreement i see message: Warning: An error occurred while preparing SDK package Android SDK Platform 28: Tag mismatch!.
Update failed. Please check the Android Studio install.ng platform-28_r06.zip…

Somebody have same result?