Failing to build demo on iOS

Looks like I might be switching mid-project from Unity to UDK. The $225 a month I’m facing at Unity to develop for mobile is making me seriously consider switching to Unreal. So sorry but I’m a total noob at the moment. I need to ramp up in about a week and start porting.

My first attempt at anything in UDK is to just build the table and chairs demo with the floating cone above it from here:

But when I try to launch it on my iPhone 6+ it fails. I’m sure I’m just missing something stupid but it’s failing to build and launch on the device and after a couple hours playing and searching here I have to ask for help.

I have verified in Project Settings > Platform Settings > iOS that I have green/valid team * provisioning profiles and a valid development certificate.

In the product launcher it fails on Deploying content for iOS. I attached the project launch log. It seems to build ok but fails when trying to copy to the device:

mono: Unhandled Exception:

mono: System.IO.IOException: AFCFileRefOpen failed with error 7

log file

Also, it’s probably unrelated. But the UE4 interface in my mac is offset from the mouse. So when I click anything it’s as if I clicked below it, about the height of the menu bar. Is this normal or just something weird going on in my install?


The AFCFileRefOpen failed with error 7 is a known issue. It’s only happening for a small percentage of people and unfortunately not here at Epic so we’ve been having trouble tracking down the problem. I have some more logging information coming in the next point release, but that won’t be until next week. Do you have a PC? If so, can you try the editor and Launch On on the PC? So far everyone who has this error doesn’t have access to a PC, so we’ve been unable to see if it Mac only or affects both (which would imply something different about the device itself).

As for the menu offset, again something we’ve heard about from other users, but we haven’t been able to reproduce it. What is it you set up? Multiple monitors of differing resolutions? What Mac OS?


Actually, I just looked at your log again, you have the second even more rare double attempt to deploy the IPA error. The last person to get this updated their install and it went away. Are you on 4.7.2?


Wow… I won the lottery! Twice?

I don’t have a PC. I do have VMWare. I’d rather not go there because it’s a can of worms. But I can if you need me to.

I am on 4.7.2. I just installed it yesterday and started trying to learn it. The window offset problem went away with a quit and restart of the editor. But the launch problem persists even after a reboot.


Should I delete and reinstall? Advice appreciated as I’m trying to get ramped up as quickly as possible. Thanks!

My mac is a 3.5 i7 Late 2013 iMac 27. 10.10 only 8 gig ram and I have the GTX780M. I’m actually ordering a 5k iMac later today.

Anything I can do to help you track down the problem?

No don’t worry about it. I have a potential fix for this particular issue, but it won’t be in 4.7.3 as I want to make sure it doesn’t break something else. And since we can’t reproduce it, I am kind of taking stab in the dark. Do you have a second device? For some people, it has worked on one device and not a second device.


Like I said, I’m ordering a new iMac later today but it’ll take a few days to get here. I’ll try reinstalling.

I used the launcher to uninstall 4.7.2. Then deleted the launcher and reinstalled it from the .dmg. Then reinstalled 4.7.2 from the launcher. It still won’t install on the phone. Then I tried launching on the mac and that one does build ok. Then back on the phone again and same thing. Attached is my log in case maybe the reinstall solved one of the two problems.

new log

My next attempt will be to create a totally new project from scratch and see if that will install. Are there any complete iOS test projects that are known to work?

I created a blank project and tried to launch that on the iPhone and got the same error. So it must have something to do with my install. The curious thing is that an app does install on my phone. When I run it I get a message. What does it mean?

Ok… So I updated all the software on my iMac. OS to 10.10.2, Xcode to 6.2. Same thing when I try to launch. Also tried on another device. An iPhone 6. Same thing. Same error messages. It appears to build the app ok and it even installs something on the phone. But then it fails. And when I run the app I get the above message.

OH… and now the Editor is also crashing a lot. I sent in that crash report along with a link to this post.

So now what? You’re saying that there won’t be a fix in 4.7.3. Can someone at Epic please email me? I’d even try a beta build. But I can’t wait weeks or months for a solution.

Lets try to get you my potential fix tomorrow. Either through PMs on the forums or some other way. Even if it doesn’t fix it, it should give me more information.

The reason why it is not running is the executable is there but none of the content, so it fails trying to load the game data.


That sounds great. Already better service than Unity. I couldn’t figure out how to PM on here. My email address is michael at badweasel dot com. Email me directly if you can. Thanks.

Ok, do you have a account? If so, we can use private messaging there. If not, I will use the e-mail above, but would prefer PM on the forums.


Sorry of course. My username is the same, badweasel. I messaged you from there. Thanks.

New log from temp build: build log

Ok, I just put a new dll in the same location I sent you earlier. Could you put that in the directory specified and try again?

Based on the log, you tripped my check to verify we could create the PublicStagin directory. That hasn’t been firing on my machine (PC), but I haven’t tested it on mac. The new dll will test for the existence of the directory and continue on in either case and we’ll see if the other fix resolves the double IPA install.


Failed again. This time:

mono: CreateDirectory (/PublicStaging) failed
mono: Unhandled Exception:
mono: System.IO.IOException: AFCFileRefOpen (/PublicStaging/UnrealTest.ipa) failed with error 7

Build Log

Another “by the way”… probably doesn’t matter but my Unreal Projects save folder is in ~ instead of ~/documents. And eventually it will be on an external drive.

Thanks for all the personal service by the way. REALLY selling me on UDK over Unity. Now to get it to compile so I can start tweaking the look as rendered on the phone.

Ok, I am not 100% sure, but this seems to imply that the PublicStaging directory doesn’t exist on your device and we can’t create it. That seems a bit odd, so I suspect my Exists function is not working correctly. I’ll need to do some research about this and make sure that it is working (won’t happen until tomorrow at this point).

However, I’m assuming you have pushed an app to the device in the past, correct? If not, maybe we need to have you deploy a single app of any kind either through iTunes or from Xcode. If so, then my guess is the directory does exist and my Exists function is not correct. That would then imply file (/PublicStaging/UnrealTest.ipa) is not getting encoded properly in the Mobile Framework (error 7) which is also odd as it printed ou to the log fine.

btw, you now have the other issue people have seen, so it looks like the double ipa and file ref error 7 may be related. At least this progress :slight_smile:


Also, could you see if you can get the log from the device? You can usually view this from the Xcode Devices window. Try to get a portion of the log from when it is attempting to deploy, That may give us some more information.