Download

Failed to run arcore template in 4.21 on galaxy s7

I tried building app with 4.20 and it works but fails with 4.21 on Launch and building apk and installing manually.

LogPlayLevel: Error: 11-14 21:23:15.701 11313 11332 D UE4 : LogPluginManager: Error: Unable to load plugin ‘DatasmithImporter’. Aborting.
LogPlayLevel: 11-14 21:23:15.703 11313 11332 D UE4 : Assertion failed: false [File:D:\Build++UE4\Sync\Engine\Source\Runtime\Launch\Private\Android\LaunchAndroid.cpp] [Line: 415]
LogPlayLevel: 11-14 21:23:15.703 11313 11332 D UE4 : Engine Preinit Failed
LogPlayLevel: 11-14 21:23:15.703 11313 11332 D UE4 : Assertion failed: false [File:D:\Build++UE4\Sync\Engine\Source\Runtime\Launch\Private\Android\LaunchAndroid.cpp] [Line: 415]
LogPlayLevel: 11-14 21:23:15.703 11313 11332 D UE4 : Engine Preinit Failed
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: === Critical error: ===
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error:
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: Assertion failed: false [File:D:\Build++UE4\Sync\Engine\Source\Runtime\Launch\Private\Android\LaunchAndroid.cpp] [Line: 415]
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: Engine Preinit Failed
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: [Callstack] 0x00000000C74A8254 (0x000000000292C254) libUE4.so!AndroidMain(android_app*) ]
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: [Callstack] 0x00000000C74B58E8 (0x00000000029398E8) libUE4.so!android_main() ]
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: [Callstack] 0x00000000C74D7160 (0x000000000295B160) libUE4.soUnknown ]
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: [Callstack] 0x00000000F0D871C4 (0x00000000000471C4) libc.soUnknown ]
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error: [Callstack] 0x00000000F0D59D9A (0x0000000000019D9A) libc.soUnknown ]
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error:
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error:
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error:
LogPlayLevel: Error: 11-14 21:23:15.703 11313 11332 D UE4 : LogAndroid: Error:

remove the line:

"Enterprise": true,

from your uproject file. I think this happens if datasmith is not also installed on 4.21 where you had it installed on 4.20

Thanks @aussieburger that did the trick!

That really has something to do with Datasmith.
So,Android project is not compatible with datasmith?

Thanks! Solved with Samsung Tablet S4.

This is also starting again in 4.22.

I had the same issue when launching on the oculus quest. removing the enterprise line helped. thank you

I am having this issue with a different plugin (realtime database) but I don’t have an enterprise line in my uproject, any ideas on what I can do? Where is this enterprise line for you guys?

if you right click your *.uproject file, open with notepad, look at the first few lines and you’ll see the enterprise entry bool value